Flyspray:: Mon, 11 Dec 2017 02:58:55 +0100 Flyspray::QCAD: Recently opened tasks https://www.qcad.org/bugtracker/ FS#1680: Alignment of text in attribute definition changes during copy/paste Floyd Mon, 11 Dec 2017 02:58:55 +0100
I changed this to align left and copied an attribute (ctrl + C) and then pasted (ctrl + V) fourteen times.

As I opened each one up with the editor to change the tag information, I noticed that every copied/pasted attribute definition had changed to align right.

I purposely set the first one back to align left and copy/pasted it a few times. Each paste had the attribute text set to align right again.


OS: Linux Mint 18.3 [64-bit]
QCAD Pro: 3.19.1.0 [64-bit]]]>
https://www.qcad.org/bugtracker/index.php?do=details&task_id=1680 https://www.qcad.org/bugtracker/index.php?do=details&task_id=1680
FS#1679: Print Preview scale format metric/imperial selection box Husky Mon, 11 Dec 2017 00:53:16 +0100
It would be nice if the scale format list would respond to the "Measurement System (for line types and hatch patterns)" setting.

If my setting is Metric:

1:1

1:2

1:5 etc etc


If my settings is imperial:

1"=1"

1"=2"

1"=4" etc etc]]>
https://www.qcad.org/bugtracker/index.php?do=details&task_id=1679 https://www.qcad.org/bugtracker/index.php?do=details&task_id=1679
FS#1678: Property Editor dialog Viki Behun Sun, 10 Dec 2017 16:00:30 +0100 so you do not see the layer name when the Property Editor is pinned to the side.
(see Forum - Suggestions and Feedback):
[[https://www.qcad.org/rsforum/viewtopic.php?f=31&t=5239]]
]]>
https://www.qcad.org/bugtracker/index.php?do=details&task_id=1678 https://www.qcad.org/bugtracker/index.php?do=details&task_id=1678
FS#1677: Dimension: Scale option grayed out in model space Husky Fri, 08 Dec 2017 19:06:21 +0100 ... impossible to chose a scale in the DIM option bar.]]> https://www.qcad.org/bugtracker/index.php?do=details&task_id=1677 https://www.qcad.org/bugtracker/index.php?do=details&task_id=1677 FS#1676: Modify > Explode: explode lines / arcs with line patterns into dash segments Andrew Mon, 04 Dec 2017 22:59:57 +0100 https://www.qcad.org/rsforum/viewtopic.php?f=32&t=4333]]> https://www.qcad.org/bugtracker/index.php?do=details&task_id=1676 https://www.qcad.org/bugtracker/index.php?do=details&task_id=1676 FS#1675: draw order incorrect using dwg2pdf to convert DXF to PDF Derek Nheiley Mon, 04 Dec 2017 22:23:14 +0100
this causes problems if we try to export a dxf to pdf and the hatching was drawn after some of the text

observed in Mac OSX El Capitan and Linux]]>
https://www.qcad.org/bugtracker/index.php?do=details&task_id=1675 https://www.qcad.org/bugtracker/index.php?do=details&task_id=1675
FS#1674: Layouts and Viewports: duplicate layout block Andrew Mon, 04 Dec 2017 15:28:34 +0100
See also:
https://www.qcad.org/rsforum/viewtopic.php?f=89&t=5241]]>
https://www.qcad.org/bugtracker/index.php?do=details&task_id=1674 https://www.qcad.org/bugtracker/index.php?do=details&task_id=1674
FS#1673: Layouts and Viewports: support polygonal viewports Andrew Mon, 04 Dec 2017 15:25:57 +0100
See also:
https://www.qcad.org/rsforum/viewtopic.php?f=89&t=5241]]>
https://www.qcad.org/bugtracker/index.php?do=details&task_id=1673 https://www.qcad.org/bugtracker/index.php?do=details&task_id=1673
FS#1672: Dimension tool displays wrong meassurement Husky Fri, 01 Dec 2017 22:24:02 +0100 Settings are:
General: Drawing Unit
Drawing Unit: Foot
Paper Unit: Inch
Measurement System: Imperial

Dimension Settings: Architectural

Issue:

I draw a horizontal line 12 units (foot) long,
Use then the Horizontal DIM tool and it will display a measurement of 1' = false,

I draw a horizontal line of 2 units (foot)long,
Use then the Horizontal DIM tool and it will display a measurement of 2" = false,

I assume the input for the line length is handled from the DIM tool as inch and not as feet.


]]>
https://www.qcad.org/bugtracker/index.php?do=details&task_id=1672 https://www.qcad.org/bugtracker/index.php?do=details&task_id=1672
FS#1671: Block > Add Layout Block: fails if layout with same name was deleted before Husky Fri, 01 Dec 2017 06:42:06 +0100
delete a Layout Block in Block List - name e.g. ANSI A P,
create a new Layout Block - try to use the deleted name (ANSI A P) again and it will be declined because the "Layout already exists.]]>
https://www.qcad.org/bugtracker/index.php?do=details&task_id=1671 https://www.qcad.org/bugtracker/index.php?do=details&task_id=1671