QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#1006 - Making zoom in / out speed configurable

Attached to Project: QCAD
Opened by Herb (huf2000) - Monday, 06 January 2014, 06:56 GMT+2
Last edited by Andrew (andrew) - Friday, 11 September 2015, 11:20 GMT+2
Task Type Feature Request
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System Mac OS X Mountain Lion
Severity Low
Priority Normal
Reported Version 3.4.5
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Although this report is specific to Magic Mouse on OS-X Mountain Lion, since mice are a fairly common commodity across all platforms, I suspect this may be a more common issue across multiple platforms. The issue is that with my Magic Mouse, when I zoom into or out of the drawing by dragging my finger forward or backward on the mouse (equivalent of rolling the scroll wheel of a mechanical mouse), the zoom keeps zooming (in either direction) LONG after I have stopped moving my finger! Now, I do have my scroll speed set high because I have a large monitor and like to get around on it fast. But QCAD is the only application that does this exaggerated scrolling, so there must be some missing conversion or time constant issue going on here. I could change the speed of my mouse and that would likely fix it: in QCAD. But then all my other apps would be too slow with the mouse. Maybe there needs to be a custom setting in the Preferences that allows to user to set the mouse speed for just inside QCAD. But I suspect its more just a mouse speed parameter conversion error.

This task depends upon

Closed by  Andrew (andrew)
Friday, 11 September 2015, 11:20 GMT+2
Reason for closing:  Implemented
Comment by Herb (huf2000) - Monday, 06 January 2014, 06:58 GMT+2

In reviewing this submission I realized that I should have noted this as severity medium since this really keeps me from doing serious work with QCAD.

Comment by Andrew (andrew) - Monday, 06 January 2014, 20:22 GMT+2

Changed to feature request for making mouse zoom speed configurable.

Comment by Andrew (andrew) - Friday, 11 September 2015, 10:26 GMT+2
the zoom keeps zooming (in either direction) LONG after I have stopped moving my finger!

Note that the magic mouse has two scrolling modes (in QCAD used for zooming):
- scroll for as long as the finger is on the mouse - the finger stays on the mouse after scrolling / zooming
- keep scrolling - the finger is lifted off the mouse directly after scrolling, application keep getting scroll events long after the finger is lifted off the mouse

While a zoom speed factor for QCAD can be introduced, this very magic mouse specific feature cannot be changed from within QCAD.

Without wanting to hurt anyones feelings, I would not recommend the magic mouse for use with CAD, mainly for the lack of a middle mouse button used in QCAD for panning.

Loading...