QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#1040 - Break out Manual on Circle/Ellipse does not respect Remove Segment setting

Attached to Project: QCAD
Opened by Tamas TEVESZ (kazmer) - Saturday, 12 April 2014, 11:35 GMT
Last edited by Andrew (andrew) - Tuesday, 15 July 2014, 08:47 GMT
Task Type Bug Report
Category Documentation
Status Closed
Assigned To Andrew (andrew)
Operating System All
Severity Low
Priority Normal
Reported Version 3.4.7
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

3.4.7 trial as well as community Git 9d3979

  • Draw a circle
  • B2
  • Make sure “Remove segment” is ticked
  • Select circle, then select two points to break out in between

Expected:

  • Segment gets removed (not really, but read on)

Actual:

  • Segment does not get removed, but circle is indeed broken into two arcs

Same for an ellipse.

I can see that by selecting two points on a closed circular shape it’s nigh impossible to tell which segment the user actually wants to remove :)

The documentation doesn’t mention this corner case. For clarity, a note detailing this effect a bit should be added to the docs.

On a slightly related note, I do not see why the feature couldn’t work on Polyline objects as well (with the same corner case restriction if it’s a closed polyline).

Very useful feature btw, thanks for it.

This task depends upon

Closed by  Andrew (andrew)
Tuesday, 15 July 2014, 08:47 GMT
Reason for closing:  Not a bug
Comment by -- (clive) - Saturday, 12 April 2014, 14:04 GMT

This works as expected for me.

The final stage asks the user in the status bar to 'click the part of the circle or ellipse to remove', works no problem!

Loading...