QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#1076 - Crash on Mac OS X when using internal Trackpad

Attached to Project: QCAD
Opened by Daniel Duke (djorlando24) - Tuesday, 22 July 2014, 21:53 GMT+1
Last edited by Andrew (andrew) - Monday, 25 August 2014, 14:57 GMT+1
Task Type Bug Report
Category QCAD/CAM
Status Closed
Assigned To Andrew (andrew)
Operating System Mac OS X (All)
Severity High
Priority High
Reported Version 3.6.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Hi,

I have just updated my Mac OS from 10.9.2 to 10.9.4. QCAD 3.6.2 seems to be working normally under the newest version of Mac OS, but has developed a very specific bug which leads to reproducible crashes when a text object is edited.

Steps to minimally reproduce:
1. Open QCAD
2. Create a text object
3. Place the text object on the canvas
4. double-click the text object and edit its contents
5. click OK to accept changes
6. repeat from step 4 three or four times.

After several attempts to edit a text object, QCAD will crash with EXC_BAD_ACCESS (SIGBUS) in thread 0 (QCoreApplication).
The crash can also be triggered by moving the text object around on the canvas (instead of editing its contents).
The bug does not require anything else (no other objects on the canvas, no particular font, occurs in both new and previously saved documents).

Apart from this bug, QCAD seems to work fine on OS X 10.9. The text editing crash did not occur before the latest OS update. No other applications on my system seem to be having any problems. If this problem can be fixed, I think QCAD will be quite usable on 10.9.

See also related bugs in:
 FS#1091 

   trace.rtf (55.3 KiB)
This task depends upon

Closed by  Andrew (andrew)
Monday, 25 August 2014, 14:57 GMT+1
Reason for closing:  Fixed
Additional comments about closing:  Fixed by patching Qt 4.8.6 in QApplicationPrivate::translateRawTouchEv ent, line 5954:
if (deviceType != QTouchEvent::TouchPad) {
(void) QApplication::sendSpontaneousEvent(widge t, &touchEvent);
}
Comment by Andrew (andrew) - Wednesday, 23 July 2014, 08:54 GMT+1

Thanks for your report.

I cannot reproduce that problem here with Mac OS X 10.9.4 and QCAD 3.6.2.

However, I noticed that it s likely connected to touch events and gestures.

Please indicate what kind of input device you are using (e.g. Apple Magic Mouse, Magic TrackPad, Wacom Tablet, Notebook with integrated touch pad, etc.).
Thanks.

Comment by Daniel Duke (djorlando24) - Wednesday, 23 July 2014, 16:57 GMT+1

I'm using a Macbook Pro (retina 15") with the built-in Apple trackpad.
I'm not using any gestures other than right/left click and the two finger up/down motion which simulates the mouse wheel.
The crash tends to occur when doing regular left-click operations, though.

Comment by Daniel Duke (djorlando24) - Wednesday, 23 July 2014, 18:18 GMT+1

Further investigation seems to suggest that if I use a regular USB mouse in QCAD, the crashes are far less frequent, so yes it appears to be something to do with the trackpad. Haven't got a reliably reproducible example of this yet.
Oddly, the action preceding a crash is always just a plain ol' left click.

Comment by Daniel Duke (djorlando24) - Monday, 28 July 2014, 21:33 GMT+1

Further update - after some time using QCAD with a USB mouse, the crashes do not occur.
Moving and editing text objects with the Macbook Pro built-in trackpad causes the crash.
This is definitely an issue with the Apple Trackpad under OS X 10.9.4.

Comment by Andrew (andrew) - Thursday, 31 July 2014, 10:49 GMT+1

This is reproducible with an internal trackpad on a MacBook Pro, but not with an Apple Magic Trackpad.

Comment by Stephen Winnall (winnall) - Monday, 11 August 2014, 23:44 GMT+1

I'm a brand new user, but I've experienced something that looks like this bug twice today. I'm using an iMac and an Apple Magic Trackpad under Mac OS X 10.9.4 and QCAD Professional v 3.6.3.0.

I attach the two crash dumps that I got in the hope that they might help to locate the source of the problem.

Regards,
Steve

Comment by Iikka Virkkunen (Iikka) - Wednesday, 20 August 2014, 08:00 GMT+1

I'm having the same issue (with similar trace on crash report).

As a temporary work-around, disabling "Application Preferences → Graphics View → Behavior → Double-click to edit text" seems to remove the crashes. The text can then be edited in the "geometry" pane or by selecting and clicking text pane.

I hope this gets fixed quickly; double-click-edit is much better.

Iikka

Comment by Daniel Duke (djorlando24) - Wednesday, 20 August 2014, 19:05 GMT+1

Thanks for figuring this out, likka! Now I can use QCAD in a pinch when I don't have a USB mouse.
I used QCAD for several hours yesterday with a USB mouse, and it didn't crash [except when I inadvertently used the trackpad].
Hopefully this bug will be fixed soon.

Comment by Andrew (andrew) - Monday, 25 August 2014, 14:52 GMT+1

The best work-around is to use an external mouse. There are various other possible crashes when using the internal trackpad on Mac OS X, typically when using tools which show dialogs (edit text, create hatch, move, mirror, rotate, ...).

Loading...