QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

Tasklist

FS#1101 - Hatch: Some patterns create point shapes around hatch boundary

Attached to Project: QCAD
Opened by Pete Martin (ac90pilot) - Wednesday, 24 September 2014, 01:58 GMT+1
Last edited by Andrew (andrew) - Wednesday, 24 September 2014, 10:37 GMT+1
Task Type Bug Report
Category QCAD (main)
Status Closed
Assigned To Andrew (andrew)
Operating System All
Severity Low
Priority Normal
Reported Version 3.6.4
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Line weight in exported pdf is sometions wrong. Example, create a polyline closed figure and hatch it with style GRAVEL, then export to PDF. The outline line width will vary depending on the actual zoom factor of the display. I believe this bug is causing points to be displayed at various sizes in the PDF.

This task depends upon

Closed by  Andrew (andrew)
Wednesday, 24 September 2014, 10:37 GMT+1
Reason for closing:  Fixed
Additional comments about closing:  https://github.com/qcad/qcad/commit/16cc dfcef0f2c3f95e430963805e4515f38c4116
Comment by Andrew (andrew) - Wednesday, 24 September 2014, 10:04 GMT+1

This appears to be a problem that is unique to the "GRAVEL" pattern.

What happens is that there are point shape artifacts created along the hatch boundary when using this pattern.
If you have chosen an alternative point display mode, this can result in the effect described in the report.

Comment by -- (clive) - Wednesday, 24 September 2014, 15:04 GMT+1 Comment by Andrew (andrew) - Wednesday, 24 September 2014, 15:08 GMT+1

No, that's a separate issue related solely to the point display modes.
This issue was caused by points created for hatch patterns which don't contain any points at all.

Comment by Pete Martin (ac90pilot) - Wednesday, 24 September 2014, 19:00 GMT+1

I first noticed this problem with the point display then found it was related to the GRAVEL pattern. The work around is to olny click PDF print when the display zoomed all the way in to some area small area of the drawing. You can veryify this bug by looking the PDF dot size when you click PDF print with the display zoomed very far out. I have only tested the linux version.

Comment by -- (clive) - Sunday, 28 September 2014, 11:18 GMT+1

Okay thanks Andrew.

Loading...