QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)


FS#1122 - Objects move inappropriately when confirming alignment by alignment tool (M,A).

Attached to Project: QCAD
Opened by Stuart Feichtinger (stuthedew) - Wednesday, 12 November 2014, 05:32 GMT+1
Last edited by Andrew (andrew) - Friday, 14 November 2014, 09:01 GMT+1
Task Type Bug Report
Category QCAD/CAM
Status Closed
Assigned To Andrew (andrew)
Operating System Mac OS X (All)
Severity Low
Priority Normal
Reported Version 3.7.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


I am trying to use the align tool (M, A) to align two text objects vertically. I am able to get them aligned how I want them, but when I confirm (click the green check box in the upper right-hand corner) they mysteriously jump up a large grid square or so. I am then able to get them back into the alignment by the “undo” command. In case that didn’t make sense I’ll try this one more time:

{Result} (User Action)

{text boxes out of alignment}(Align tool “M,A”){text boxes aligned}(click green checkmark){text boxes move randomly}(undo “ctrl-z”){text boxes aligned}

I’m thinking this is either operator error or a bug. It is consistent though.

This task depends upon

Closed by  Andrew (andrew)
Friday, 14 November 2014, 09:01 GMT+1
Reason for closing:  Fixed
Comment by Husky (Husky) - Wednesday, 12 November 2014, 09:37 GMT+1


Which option have you used for "Align to:"? "Picked Entity" or "Drawing"?

For "Drawing" you have to use the green check-mark button,
for "Picked Entity" you have just to use the left mouse button in the drawing to confirm a correct alignment and then close the tool with the red X Button,

Comment by Andrew (andrew) - Wednesday, 12 November 2014, 14:13 GMT+1

I cannot reproduce this here with either setting.
Could you attach or e-mail the drawing and explain step by step how you proceed to reproduce this?

Comment by Stuart Feichtinger (stuthedew) - Thursday, 13 November 2014, 00:05 GMT+1

Husky and Andrew,
Thank you both very much for getting back to me so quickly. Husky, I was trying to align to "Picked Entity," and your solution of clicking the red X worked great. This idiosyncrasy still strikes me as unintended though, so I attached a video showing what I mean just in case. I originally tried to reproduce this using a new file with only two text boxes, but it did't work (i.e. clicking the green checkmark accepted and everything stayed in place). However, it is still moving consistently as previously described in the file in which I originally had the issue. I hope this quick screen grab is more illustrative of what I'm talking about. Thank you both again!


Stuart Feichtinger

Comment by Andrew (andrew) - Thursday, 13 November 2014, 09:21 GMT+1

Thanks for the video. Is there any chance that you could attach or e-mail that drawing file, since the problem only seems to affect that particular drawing? Thanks.

Comment by Stuart Feichtinger (stuthedew) - Friday, 14 November 2014, 01:09 GMT+1

Here you go. Not that it's important, but in case you are wondering about the file: My fiancé are getting married this summer, so I put our venue's floor plan into QCAD to figure out how much space we had, table arrangement etc. And yes, the barn really does have a bowling alley. Thanks for the help!


Comment by Andrew (andrew) - Friday, 14 November 2014, 09:01 GMT+1

Thanks! I was able to reproduce the problem now and fixed it for the next release.