QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#123 - QCAD Save Fails, File Created Zero Bytes and then complains no permissions

Attached to Project: QCAD
Opened by james a r brown (jamesarbrown) - Thursday, 30 June 2011, 15:20 GMT+1
Last edited by Andrew (andrew) - Friday, 05 August 2011, 15:36 GMT+1
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System Linux (All / Other)
Severity High
Priority Normal
Reported Version 3 TP1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi,

uname -r
2.6.38.8-32.fc15.x86_64

We can save a file ok showing permissions on the linux system are ok (its home directory)

But then when we open a CAD file from a supplier, try and modify and save or save as, it complains about disk space / permissions.

However, on checking the file system, the file name is there at zero bytes.

It is felt it is something in the CAD file causing an error behind the scenes. I can not see anywhere to attach this file, so please email me and I will send.

James

This task depends upon

Closed by  Andrew (andrew)
Friday, 05 August 2011, 15:36 GMT+1
Reason for closing:  Fixed
Additional comments about closing:  Was caused by XData which will be ignored in QCAD 3 Beta 1.
Comment by Andrew (andrew) - Thursday, 30 June 2011, 15:26 GMT+1

Please send us the file to info [at] ribbonsoft [dot] com and confirm briefly that you are using QCAD 3 TP1 on Fedora Core 15, 64bit.

Comment by james a r brown (jamesarbrown) - Thursday, 30 June 2011, 15:30 GMT+1

Ahha.... here is file in question..1,8MB... maybe thats problem, large files.

Comment by Peter (hungerburg) - Saturday, 02 July 2011, 11:36 GMT+1

I experienced the same problem with drawings. The issue cannot be filesize. I suspect the drawings use features of dxf/dwg that TP1 cannot handle: e.g. when I insert a block definition (I can do this, but not add a reference in the drawing...), save will produce same message and an empty file.

Loading...