QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

Tasklist

FS#1236 - Arrow heads on leaders are missing every time files are opened.

Attached to Project: QCAD
Opened by Fred Baggs (SwarfMaker) - Wednesday, 15 July 2015, 14:05 GMT+1
Last edited by Andrew (andrew) - Monday, 04 January 2016, 17:34 GMT+1
Task Type Bug Report
Category QCAD (main)
Status Closed
Assigned To Andrew (andrew)
Operating System Windows 7
Severity Low
Priority Normal
Reported Version 3.9.5
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Arrow heads on leaders are missing every time files are opened.

This task depends upon

Closed by  Andrew (andrew)
Monday, 04 January 2016, 17:34 GMT+1
Reason for closing:  Fixed
Comment by Fred Baggs (SwarfMaker) - Wednesday, 15 July 2015, 14:06 GMT+1

This bug has been present for several earlier versions.

Comment by Andrew (andrew) - Wednesday, 15 July 2015, 14:10 GMT+1

I cannot reproduce this here. My procedure is as follows:
- File > New
- Draw leader with arrow head
- Save file as DXF R27
- Close file
- Load file
→ Arrow head is still present.

Can you confirm that this same procedure leads to a leader without arrow head on your installation? Thanks.

Comment by Andrew (andrew) - Wednesday, 15 July 2015, 14:14 GMT+1

Note:
If the first segment of the leader is to short to host the arrow, the arrow is disabled automatically. This is not a bug but an unfortunate imposition of the DXF / DWG format.
If you can attach the file in question, I can check if that is indeed the problem. Thanks.

Comment by Fred Baggs (SwarfMaker) - Wednesday, 15 July 2015, 15:11 GMT+1

Gosh Andrew, that was quick!

This file retains the arrows on leaders when opened in version 3.8.1 but not on later versions.

I don't know at what version the change occurred although I have just tried version 3.9.1 and the arrows are missing.

Attached file is the one that caught my attention. It is in R27 format.

Fred

Comment by Fred Baggs (SwarfMaker) - Wednesday, 15 July 2015, 16:21 GMT+1

Gosh Andrew, that was quick!

This file retains the arrows on leaders when opened in version 3.8.1 but not on later versions.

I don't know at what version the change occurred although I have just tried version 3.9.1 and the arrows are missing.

Attached file is the one that caught my attention. It is in R27 format.

Fred

Comment by Jacob Nielsen (chibot) - Monday, 04 January 2016, 17:32 GMT+1

Bug persists, at least partially, in 3.12.4. File in R27 format containing a single leader, which loses its arrowhead when saved and reloaded: https://www.dropbox.com/s/uyi93yyz1l5sjpk/leader_test.dxf?dl=1 (from a 20:1 scale drawing - turn on print preview mode)

Loading...