QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

Tasklist

FS#1245 - Zoom in / zoom out: drawing painted at inconsistent offsets

Attached to Project: QCAD
Opened by Husky (Husky) - Monday, 27 July 2015, 23:03 GMT+1
Last edited by Andrew (andrew) - Tuesday, 28 July 2015, 00:38 GMT+1
Task Type Bug Report
Category QCAD (main)
Status Closed
Assigned To Andrew (andrew)
Operating System Windows (All)
Severity Low
Priority Normal
Reported Version 3.9.6
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Zooming in or out repeatedly (keeping + or - key pressed or using mouse wheel) shows the drawing at incorrect offsets in between frames with the correct offset.

Original report:

Zoom in and out with the Mouse wheel is working but it is unfortunately jumping in a zickzack course.

This task depends upon

Closed by  Andrew (andrew)
Tuesday, 28 July 2015, 00:38 GMT+1
Reason for closing:  Fixed
Additional comments about closing:  https://github.com/qcad/qcad/commit/5288 577085b4a2388f713a05764b35920b60f76d
Comment by Husky (Husky) - Monday, 27 July 2015, 23:51 GMT+1

Additional info: Using the Toolbar symbols or the shortcut commands for zoom in or out will show the same behavior.

Comment by Andrew (andrew) - Tuesday, 28 July 2015, 00:34 GMT+1

Caused by 'repaint' used in RGraphicsViewQt when compiled against Qt 4.7.

Loading...