QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#125 - Modify Tools Not Working - Linux X86

Attached to Project: QCAD
Opened by james a r brown (jamesarbrown) - Thursday, 30 June 2011, 16:31 GMT+1
Last edited by Andrew (andrew) - Thursday, 30 June 2011, 16:38 GMT+1
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System Linux (All / Other)
Severity High
Priority Normal
Reported Version 3 TP1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi,

When utilising the modify tools, instead of the selection picker appearing, the menu drops back to the start.

The console says
Warning: QScriptEngine::newVariant(): changing class of non-QScriptObject not supported
Warning: QScriptEngine::newVariant(): changing class of non-QScriptObject not supported

Have tried with rotate, copy/move, mirror etc.

Fedora 15 x86_64

James

This task depends upon

Closed by  Andrew (andrew)
Thursday, 30 June 2011, 16:38 GMT+1
Reason for closing:  Not a bug
Comment by Andrew (andrew) - Thursday, 30 June 2011, 16:38 GMT+1

Yes, this is the reason why QCAD 3 TP1 is marked as 'technology preview'.
It is not complete and was released only for interested developers.

See also "readme.txt" which is contained in all TP1 packages and displayed when QCAD 3 TP1 is started:

Known limitations:

- Modification tools are not implemented.
- Measuring tools are not implemented.
- Image (bitmap) related tools are not implemented.
- Isometric projection tools are not implemented.
- Block related tools are not implemented (blocks are supported but not on the user interface level)
- SVG export has several limitations in connection with text entities.
- Layer locking is not implemented.
- Snap restrictions (horizontal, vertical, orthogonal) are not implemented.
- Help manual is not available
Comment by james a r brown (jamesarbrown) - Thursday, 30 June 2011, 17:21 GMT+1

Ahh ok, had missed that.

Realised some things not implemented like fit to page on print preview.

James

Loading...