QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

Tasklist

FS#1261 - Unable to open dxf files saved by QCad in QCad.

Attached to Project: QCAD
Opened by Neil Baker (NeilBaker) - Monday, 07 September 2015, 17:20 GMT+1
Last edited by Andrew (andrew) - Monday, 07 September 2015, 17:38 GMT+1
Task Type Bug Report
Category QCAD (main)
Status Closed
Assigned To Andrew (andrew)
Operating System OpenSUSE Linux
Severity Critical
Priority Normal
Reported Version 3.10.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I am unable to open dxf files saved by QCad in QCad. I was initially using pro version 3.10, when I first encountered this problem (details below)
I then tried reverting to pro version 3.7.7.0 and also saving dxf files as R24, as this configuration has always worked with no problems until now.
I can not now open a file saved by QCad this morning using pro 3.7.7.0 and saving in R24 dxf format. This worked ok for two days.
I can view this file in FreeCad however! Sadly that is just not capable of achieving my goal.
I am currently unable to do any work and have lost four days attempting to overcome this problem.
This is the first problem I have ever had with QCad,I recommend it to my friends and colleagues as a particularly solid application.

File attached: R24_outlineGA;31dxf.dxf

Versions
QCAD version: 3.10.0.0
Date: Aug 24 2015
Qt version: 4.8.4
Compiler version: gcc 4.4.3
OS: Linux
OS version: Unknown

Locale
QCAD locale: en
Name: en_GB
Country: 224
Country name: United Kingdom
Language: 31
Language name: British English
Script: 0
Script name: Default
Decimal point: 46
Negative sign: 45
Positive sign: 43
Text direction: 0
System codec: UTF-8

Arguments: ./qcad-bin,-style,plastique

Plugins
Description=Import and export support for the DXF and DWG format and support for splines from fit points. Based on ODA Teigha®.
FileName=/archive/Com/com/downloaded/bin/qcad/qcad-3.10.0-pro-linux-x86_64/plugins/libqcaddwg.so
ID=DWG
License=Proprietary
Name=QCAD Pro
PurchaseURL=http://ribbonsoft.com/add-ons/qcadpro-purchase
QtVersion=4.8.4
SystemCodePage=0
URL=http://ribbonsoft.com/add-ons/qcadpro
Version=3.10.0 (Teigha® 3.09.1.0)

Description=Import support for the DXF format. Based on dxflib.
FileName=/archive/Com/com/downloaded/bin/qcad/qcad-3.10.0-pro-linux-x86_64/plugins/libqcaddxf.so
ID=DXF
License=GPLv2+
Name=DXF
QtVersion=4.8.4
URL=http://www.qcad.org
Version=3.10.0 (dxflib 3.7.5.0)

Description=Integrated help browser.
FileName=/archive/Com/com/downloaded/bin/qcad/qcad-3.10.0-pro-linux-x86_64/plugins/libqcadhelp.so
ID=HELP
License=Proprietary
Name=QCAD Pro
QtVersion=4.8.4
URL=http://www.ribbonsoft.com
Version=3.10.0

Description=Polygon clipping, boolean polygon operations, path offset.
FileName=/archive/Com/com/downloaded/bin/qcad/qcad-3.10.0-pro-linux-x86_64/plugins/libqcadpolygon.so
ID=POLYGON
License=Proprietary
Name=QCAD Pro
PurchaseURL=http://ribbonsoft.com/add-ons/qcadpro-purchase
QtVersion=4.8.4
URL=http://ribbonsoft.com/add-ons/qcadpro
Version=3.10.0

Description=QCAD Professional tools.
FileName=/archive/Com/com/downloaded/bin/qcad/qcad-3.10.0-pro-linux-x86_64/plugins/libqcadproscripts.so
ID=PROTOOLS
License=Proprietary
Name=QCAD Pro
NamePostfix= Professional
PurchaseURL=http://ribbonsoft.com/add-ons/qcadpro-purchase
QtVersion=4.8.4
URL=http://ribbonsoft.com/add-ons/qcadpro
Version=3.10.0

Environment
KONSOLE_DBUS_WINDOW=/Windows/1
XCURSOR_SIZE=0
JAVA_BINDIR=/usr/lib64/jvm/jre/bin
LESS_ADVANCED_PREPROCESSOR=no
JRE_HOME=/usr/lib64/jvm/jre
XCURSOR_THEME=Oxygen_Blue
GTK_MODULES=canberra-gtk-module
XKEYSYMDB=/usr/X11R6/lib/X11/XKeysymDB
JAVA_HOME=/usr/lib64/jvm/jre
MAIL=/var/spool/mail/neil
MACHTYPE=x86_64-suse-linux
XDG_SESSION_ID=1
XDG_DATA_DIRS=/usr/share:/usr/share:/etc/opt/kde3/share:/opt/kde3/share
PAGER=less
KDE_NO_IPV6=1
GPG_AGENT_INFO=/tmp/gpg-l7ephR/S.gpg-agent:1149:1
KDE_SESSION_UID=1000
AUDIODRIVER=pulseaudio
PILOTPORT=usb:
NNTPSERVER=news
PATH=/opt/OpenPrinting-Gutenprint/sbin:/opt/OpenPrinting-Gutenprint/bin:/home/neil/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/games:/opt/kde3/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin
PROMPT_COMMAND=history -a
XAUTHLOCALHOSTNAME=Stothert
WINDOWMANAGER=/usr/bin/startkde
GPG_TTY=/dev/pts/1
KDE_FULL_SESSION=true
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-pru8X8mc8o,guid=00a2d1328eb37df0566779b855eda10f
CONFIG_SITE=/usr/share/site/x86_64-unknown-linux-gnu
XDG_VTNR=7
SSH_ASKPASS=/usr/lib/ssh/ksshaskpass
QT_PLUGIN_PATH=/home/neil/.kde4/lib64/kde4/plugins/:/usr/lib64/kde4/plugins/
HOSTNAME=Stothert
CVS_RSH=ssh
LANGUAGE=
TMPDIR=/tmp
G_BROKEN_FILENAMES=1
GS_LIB=/home/neil/.fonts
SHELL_SESSION_ID=e541a82f5bfa40008d6eb664c682a430
SDL_AUDIODRIVER=pulse
CPU=x86_64
DESKTOP_SESSION=default
GTK_IM_MODULE=cedilla
KDE_MULTIHEAD=false
LANG=en_GB.UTF-8
HOST=Stothert
JAVA_ROOT=/usr/lib64/jvm/jre
PYTHONSTARTUP=/etc/pythonstart
LESSKEY=/etc/lesskey.bin
XNLSPATH=/usr/share/X11/nls
SSH_AGENT_PID=1148
SESSION_MANAGER=local/Stothert:@/tmp/.ICE-unix/1515,unix/Stothert:/tmp/.ICE-unix/1515
KONSOLE_DBUS_SERVICE=:1.89
INPUTRC=/home/neil/.inputrc
PWD=/archive/Com/com/downloaded/bin/qcad/qcad-3.10.0-pro-linux-x86_64
LOGNAME=neil
COLORTERM=1
XSESSION_IS_UP=yes
MORE=-sl
LESSOPEN=lessopen.sh %s
PROFILEREAD=true
SSH_AUTH_SOCK=/tmp/ssh-cTHJf7mvbfas/agent.1046
KONSOLE_PROFILE_NAME=Shell
ALSA_CONFIG_PATH=/etc/alsa-pulse.conf
WINDOWPATH=7
XDM_MANAGED=method=classic,auto
HOME=/home/neil
UNICODEMAP_JP=cp932
GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/neil/.gtkrc-2.0-kde4:/home/neil/.gtkrc-2.0:/home/neil/.kde4/share/config/gtkrc-2.0
FROM_HEADER=
LS_COLORS=no=00:fi=00:di=01;34:ln=00;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=41;33;01:ex=00;32:*.cmd=00;32:*.exe=01;32:*.com=01;32:*.bat=01;32:*.btm=01;32:*.dll=01;32:*.tar=00;31:*.tbz=00;31:*.tgz=00;31:*.rpm=00;31:*.deb=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.lzma=00;31:*.zip=00;31:*.zoo=00;31:*.z=00;31:*.Z=00;31:*.gz=00;31:*.bz2=00;31:*.tb2=00;31:*.tz2=00;31:*.tbz2=00;31:*.xz=00;31:*.avi=01;35:*.bmp=01;35:*.fli=01;35:*.gif=01;35:*.jpg=01;35:*.jpeg=01;35:*.mng=01;35:*.mov=01;35:*.mpg=01;35:*.pcx=01;35:*.pbm=01;35:*.pgm=01;35:*.png=01;35:*.ppm=01;35:*.tga=01;35:*.tif=01;35:*.xbm=01;35:*.xpm=01;35:*.dl=01;35:*.gl=01;35:*.wmv=01;35:*.aiff=00;32:*.au=00;32:*.mid=00;32:*.mp3=00;32:*.ogg=00;32:*.voc=00;32:*.wav=00;32:
XDG_SEAT=seat0
USE_FAM=
XMODIFIERS=@im=local
WINDOWID=102760474
QT_IM_MODULE=xim
BASH_FUNC_mc%%=() {  . /usr/share/mc/mc-wrapper.sh
}
KDE_SESSION_VERSION=4
SHLVL=3
QT_SYSTEM_DIR=/usr/share/desktop-data
COLORFGBG=15;0
MANPATH=/opt/OpenPrinting-Gutenprint/man:/usr/local/man:/usr/share/man:/opt/kde3/share/man
G_FILENAME_ENCODING=@locale,UTF-8,ISO-8859-15,CP1252
KONSOLE_DBUS_SESSION=/Sessions/1
DISPLAY=:0
CSHEDIT=emacs
XDG_CURRENT_DESKTOP=KDE
XDG_CONFIG_DIRS=/etc/xdg
_=./qcad-bin
DM_CONTROL=/var/run/xdmctl
SHELL=/bin/bash
LS_OPTIONS=-N --color=tty -T 0
MINICOM=-c on
XDG_RUNTIME_DIR=/run/user/1000
GTK_RC_FILES=/etc/gtk/gtkrc:/home/neil/.gtkrc:/home/neil/.kde4/share/config/gtkrc
OSTYPE=linux
QEMU_AUDIO_DRV=pa
PROFILEHOME=
LD_LIBRARY_PATH=.
HISTSIZE=1000
TERM=xterm
HOSTTYPE=x86_64
LESSCLOSE=lessclose.sh %s %s
LESS=-M -I -R
QT_IM_SWITCHER=imsw-multi
USER=neil
HISTCONTROL=ignoreboth
Versions
QCAD version: 3.7.7.0
Date: Jan 20 2015
Qt version: 4.8.4
Compiler version: gcc 4.4.3
OS: Linux
OS version: Unknown

Locale
QCAD locale: en
Name: en_GB
Country: 224
Country name: United Kingdom
Language: 31
Language name: British English
Script: 0
Script name: Default
Decimal point: 46
Negative sign: 45
Positive sign: 43
Text direction: 0
System codec: UTF-8

Arguments: /archive/Com/com/downloaded/bin/qcad/qcad-3.7.7-pro-linux-x86_64/qcad-bin,-style,plastique

Plugins
Description=Import and export support for the DXF and DWG format and support for splines from fit points. Based on ODA Teigha®.
FileName=/archive/Com/com/downloaded/bin/qcad/qcad-3.7.7-pro-linux-x86_64/plugins/libqcaddwg.so
License=Proprietary
Name=DWG
PurchaseURL=http://ribbonsoft.com/add-ons/qcaddwg-purchase
QtVersion=4.8.4
SystemCodePage=0
URL=http://ribbonsoft.com/add-ons/qcaddwg
Version=3.7.7 (Teigha® 3.09.1.0)

Description=Import support for the DXF format. Based on dxflib.
FileName=/archive/Com/com/downloaded/bin/qcad/qcad-3.7.7-pro-linux-x86_64/plugins/libqcaddxf.so
License=GPLv2+
Name=DXF
QtVersion=4.8.4
URL=http://www.qcad.org
Version=3.7.7 (dxflib 3.7.5.0)

Description=Integrated help browser.
FileName=/archive/Com/com/downloaded/bin/qcad/qcad-3.7.7-pro-linux-x86_64/plugins/libqcadhelp.so
License=Proprietary
Name=Help Browser
QtVersion=4.8.4
URL=http://www.ribbonsoft.com
Version=3.7.7

Description=Script collection of QCAD Professional tools.
FileName=/archive/Com/com/downloaded/bin/qcad/qcad-3.7.7-pro-linux-x86_64/plugins/libqcadproscripts.so
License=Proprietary
Name=Pro Tools
PurchaseURL=http://ribbonsoft.com/add-ons/qcadpro-purchase
QtVersion=4.8.4
URL=http://ribbonsoft.com/add-ons/qcadpro
Version=3.7.7

Environment
XCURSOR_SIZE=0
JAVA_BINDIR=/usr/lib64/jvm/jre/bin
LESS_ADVANCED_PREPROCESSOR=no
JRE_HOME=/usr/lib64/jvm/jre
XCURSOR_THEME=Oxygen_Blue
GTK_MODULES=canberra-gtk-module
XKEYSYMDB=/usr/X11R6/lib/X11/XKeysymDB
JAVA_HOME=/usr/lib64/jvm/jre
MAIL=/var/spool/mail/neil
MACHTYPE=x86_64-suse-linux
XDG_SESSION_ID=1
XDG_DATA_DIRS=/usr/share:/usr/share:/etc/opt/kde3/share:/opt/kde3/share
PAGER=less
KDE_NO_IPV6=1
GPG_AGENT_INFO=/tmp/gpg-l7ephR/S.gpg-agent:1149:1
KDE_SESSION_UID=1000
AUDIODRIVER=pulseaudio
PILOTPORT=usb:
NNTPSERVER=news
PATH=/opt/OpenPrinting-Gutenprint/sbin:/opt/OpenPrinting-Gutenprint/bin:/home/neil/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/games:/opt/kde3/bin:/usr/lib/mit/bin:/usr/lib/mit/sbin
PROMPT_COMMAND=history -a
XAUTHLOCALHOSTNAME=Stothert
WINDOWMANAGER=/usr/bin/startkde
GPG_TTY=not a tty
KDE_FULL_SESSION=true
DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-pru8X8mc8o,guid=00a2d1328eb37df0566779b855eda10f
CONFIG_SITE=/usr/share/site/x86_64-unknown-linux-gnu
XDG_VTNR=7
SSH_ASKPASS=/usr/lib/ssh/ksshaskpass
QT_PLUGIN_PATH=/home/neil/.kde4/lib64/kde4/plugins/:/usr/lib64/kde4/plugins/
HOSTNAME=Stothert
CVS_RSH=ssh
LANGUAGE=
TMPDIR=/tmp
G_BROKEN_FILENAMES=1
GS_LIB=/home/neil/.fonts
SDL_AUDIODRIVER=pulse
CPU=x86_64
DESKTOP_SESSION=default
GTK_IM_MODULE=cedilla
KDE_MULTIHEAD=false
LANG=en_GB.UTF-8
HOST=Stothert
JAVA_ROOT=/usr/lib64/jvm/jre
PYTHONSTARTUP=/etc/pythonstart
LESSKEY=/etc/lesskey.bin
XNLSPATH=/usr/share/X11/nls
SSH_AGENT_PID=1148
SESSION_MANAGER=local/Stothert:@/tmp/.ICE-unix/1515,unix/Stothert:/tmp/.ICE-unix/1515
INPUTRC=/home/neil/.inputrc
PWD=/home/neil
LOGNAME=neil
COLORTERM=1
XSESSION_IS_UP=yes
MORE=-sl
LESSOPEN=lessopen.sh %s
PROFILEREAD=true
SSH_AUTH_SOCK=/tmp/ssh-cTHJf7mvbfas/agent.1046
ALSA_CONFIG_PATH=/etc/alsa-pulse.conf
WINDOWPATH=7
XDM_MANAGED=method=classic,auto
HOME=/home/neil
UNICODEMAP_JP=cp932
GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/neil/.gtkrc-2.0-kde4:/home/neil/.gtkrc-2.0:/home/neil/.kde4/share/config/gtkrc-2.0
FROM_HEADER=
XDG_SEAT=seat0
USE_FAM=
XMODIFIERS=@im=local
QT_IM_MODULE=xim
BASH_FUNC_mc%%=() {  . /usr/share/mc/mc-wrapper.sh
}
KDE_SESSION_VERSION=4
SHLVL=2
QT_SYSTEM_DIR=/usr/share/desktop-data
MANPATH=/opt/OpenPrinting-Gutenprint/man:/usr/local/man:/usr/share/man:/opt/kde3/share/man
G_FILENAME_ENCODING=@locale,UTF-8,ISO-8859-15,CP1252
DISPLAY=:0
CSHEDIT=emacs
XDG_CURRENT_DESKTOP=KDE
XDG_CONFIG_DIRS=/etc/xdg
_=/archive/Com/com/downloaded/bin/qcad/qcad-3.7.7-pro-linux-x86_64/qcad-bin
DM_CONTROL=/var/run/xdmctl
SHELL=/bin/bash
MINICOM=-c on
XDG_RUNTIME_DIR=/run/user/1000
GTK_RC_FILES=/etc/gtk/gtkrc:/home/neil/.gtkrc:/home/neil/.kde4/share/config/gtkrc
OSTYPE=linux
QEMU_AUDIO_DRV=pa
LD_LIBRARY_PATH=/archive/Com/com/downloaded/bin/qcad/qcad-3.7.7-pro-linux-x86_64
HISTSIZE=1000
HOSTTYPE=x86_64
TERM=xterm
LESSCLOSE=lessclose.sh %s %s
LESS=-M -I -R
QT_IM_SWITCHER=imsw-multi
USER=neil
HISTCONTROL=ignoreboth
This task depends upon

Closed by  Andrew (andrew)
Monday, 07 September 2015, 17:38 GMT+1
Reason for closing:  Not a bug
Additional comments about closing:  Problem caused by very large circles in drawing file. Deleting the circles fixes the problem.
Comment by Andrew (andrew) - Monday, 07 September 2015, 17:29 GMT+1

Please attach the relevant DXF files, thanks.

Comment by Andrew (andrew) - Monday, 07 September 2015, 17:37 GMT+1

Received files via e-mail.

Problem due to very large entities (circles).

Comment by Andrew (andrew) - Monday, 07 September 2015, 17:48 GMT+1

I've posted a tip to fix such problems in the forum at:
http://www.qcad.org/rsforum/viewtopic.php?f=47&t=3702

Loading...