QCAD Bugtracker

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category QCAD (main)
  • Assigned To
    Andrew
  • Operating System Mac OS X (All)
  • Severity High
  • Priority Very Low
  • Reported Version 3.11.3
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: QCAD Bugtracker
Opened by Jon McCoy - 27.10.2015
Last edited by Andrew - 02.02.2016

FS#1286 - Canvas flickers/flashes white when scrolling.

When scrolling quickly, the entire canvas flashes white (some kind of video buffer issue?). This includes the rulers, but excludes the scroll bars and the corner fillet at the top-left between the two rulers. Frequency of flicker is linked to speed too - the more you scroll the fast the flicker.

I’ve marked the severity high - obviously this is not a functional problem, but the strobe effect is causing headaches and may have negative affects for people with illnesses triggered by flashing light. Even with the background set to white, the flashing is still severe - when the background is set to black, it’s unbearable.

Using a Mac Pro (10.10.3) with AMD FirePro D300 2048 MB graphics and dual displays. Happens on either of the displays. Was using an August 2013 build with the issue - just upgraded to latest build and have same issue. Didn’t experience this on previous/older Mac Pro (running 10.8), so suspect it’s an issue with hardware or OS version?

Closed by  Andrew
02.02.2016 07:15
Reason for closing:  Not a bug
Additional comments about closing:  

Problem was solved outside of the scope of QCAD.

Admin
Andrew commented on 27.10.2015 13:06
so suspect it’s an issue with hardware or OS version?

There are currently no known problems with Mac OS 10.10. I don't have an Apple system with an external display here for testing, so that might be a potential issue.

Admin
Andrew commented on 14.01.2016 09:59

You might want to test the new 64bit package for Mac OS X which is based on newer libraries, to see if the problem persists.

Jon McCoy commented on 01.02.2016 18:00

Since the the original report, I upgraded to El Capitan and tried 3.11.3 before replacing it with the new version, and it seems to work. It would appear it was an issue with 10.10 (maybe 10.9 too), but has been fixed with 10.11. Worth noting that the new version works on 10.11 without issues, in addition to 3.11.3.

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing