QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

Tasklist

FS#1293 - Crash when snapping to intersection points between 3d lines and splines

Attached to Project: QCAD
Opened by Jean-Fran├žois Lemaire (Jef) - Wednesday, 11 November 2015, 22:03 GMT+1
Last edited by Andrew (andrew) - Friday, 13 November 2015, 09:33 GMT+1
Task Type Bug Report
Category QCAD/CAM
Status Closed
Assigned To Andrew (andrew)
Operating System OpenSUSE Linux
Severity Medium
Priority Normal
Reported Version 3.12.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I have a file that makes QCAD crash. I’ve been editing this design across different versions of QCAD over time and this is the first time I have a problem with it.

Steps to reproduce:
Open the attached file and try to add some entities or dimensions to it (you may need to create large ones since it seems to depend on the zoom factor; for example a very large ellipse). After a freeze of a few seconds QCAD will quit.

The attached file is a simplified version from which I deleted a number of entities; on the original I can’t do anything – QCAD crashes as soon as I try to create any object.

Cause: 3D lines with x1==x2, y1==y2 but z1!=z2

This task depends upon

Closed by  Andrew (andrew)
Friday, 13 November 2015, 09:33 GMT+1
Reason for closing:  Fixed
Comment by Andrew (andrew) - Thursday, 12 November 2015, 08:47 GMT+1

Please attach or e-mail the files in question. Thanks.

Comment by Andrew (andrew) - Friday, 13 November 2015, 09:31 GMT+1

Workaround:
Delete 3D Infinite Line in Z direction:
- Load drawing file
- View > Selection Filter
- Entity Type: Infinite Line
- Property: Size : Height
- Comparison: = (equal to)
- Value: 0
- Click first button (Replace the current selection)
- Edit > Delete
- File > Save

Loading...