QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

Tasklist

FS#1294 - Hatches scale differently now from earlier releases

Attached to Project: QCAD
Opened by Peter (hungerburg) - Thursday, 12 November 2015, 21:38 GMT+1
Last edited by Andrew (andrew) - Friday, 13 November 2015, 12:08 GMT+1
Task Type Bug Report
Category dxflib
Status Closed
Assigned To Andrew (andrew)
Operating System All
Severity Medium
Priority Normal
Reported Version 3.12.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Something with hatching changed between 3.10 and 3.12; Changelog for 3.11.2 states: “Add support for hatch patterns defined per entity”. That may be?

Attached drawing from an older version; open in current and see a black box where there should be earth. Change scaling of hatch from 10 to 254 and it will be exactly the same it was when saving the file.

Curiously, that is like swapping inches and mm? Looking into prefs, there is a new drop down: “Messsytem für Linien und Schraffuren” and it read “imperial”; making it metric and bingo, my drawing looks as intended!

This is bad, because each drawing has to be changed! I changed the application default drawing setting to metric and the existing drawing still had imperial set…

Probably a heuristic was on order? If the drawing does not specify the new setting, and the drawing units is metric, use metric?

   ffok.dxf (25.8 KiB)
This task depends upon

Closed by  Andrew (andrew)
Friday, 13 November 2015, 12:08 GMT+1
Reason for closing:  Fixed
Comment by Peter (hungerburg) - Thursday, 12 November 2015, 22:04 GMT+1

Besides, when saving to R15 dxflib (free only has this?), the setting remains "metric" but the hatch is wrong anyways. Only saving to teigha will make the change carry over a save / load cycle.

Comment by Andrew (andrew) - Friday, 13 November 2015, 12:07 GMT+1

Affects drawings created with dxflib which lack MEASUREMENT variable and are metric.

Loading...