QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

Tasklist

FS#1385 - Default unit for new drawings reset to Inch on restart

Attached to Project: QCAD
Opened by Konekted (konekted) - Tuesday, 16 February 2016, 20:51 GMT+1
Last edited by Andrew (andrew) - Wednesday, 17 February 2016, 11:05 GMT+1
Task Type Bug Report
Category QCAD (main)
Status Closed
Assigned To Andrew (andrew)
Operating System All
Severity Low
Priority Normal
Reported Version 3.12.7
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Application Preferences > Defaults for New Drawings > Drawing Units

Do not save new selected value, It keeps “Inch”.

Could be changed per file in Edit > Drawing Preferences. I normally use Millimeter. I have no tested in command line / automation mode.

Error tested in:
Mac OS X 10.11.2 El Capitan
Mac OX X 10.7.5 Server Lion
Windows 10 (also with QCad fresh install)

This task depends upon

Closed by  Andrew (andrew)
Wednesday, 17 February 2016, 11:05 GMT+1
Reason for closing:  Fixed
Comment by Andrew (andrew) - Wednesday, 17 February 2016, 09:11 GMT+1

I cannot reproduce this problem here.

Please note that changing the default unit for new drawings only affects drawings that are created after the preference has been changed (using File > New).
This preference does not effect any drawing that are already open and it does not affect any of the drawings saved on disk.

Please follow this exact procedure:
1. Edit > Application Preferences > Defaults for New Drawings > Drawing Unit > Millimeter
2. OK
3. File > New
4. Edit > Drawing Preferences > General > Drawing Unit
5. Verify that drawing unit is set to 'Millimeter'

Please confirm.

Comment by Husky (Husky) - Wednesday, 17 February 2016, 10:53 GMT+1

I have the same problem with Win XP:
My Application preferences for "Drawing unit" is mm. The last update changed my setting for that to inch. All default (QCAD start drawing) and new drawings are now in inch.
If I change my settings in Application Preferences to mm it will work during the current session for all new drawings. After a restart of QCAD the setting mm is lost and I'm back to inch ...

Comment by Andrew (andrew) - Wednesday, 17 February 2016, 11:05 GMT+1

Thanks for the details Husky, restarting causes the problem to show up indeed.

Comment by Konekted (konekted) - Wednesday, 17 February 2016, 14:27 GMT+1

Sorry, I could be more explicit in the bug description. When I told "save" I have had said "on restart" because in the session it was applied to new files.

Thank you.

Loading...