QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#149 - SIGABRT when trying to use entiy.setColor()

Attached to Project: QCAD
Opened by Martin (martin) - Wednesday, 27 July 2011, 14:31 GMT+2
Last edited by Andrew (andrew) - Tuesday, 23 April 2013, 11:38 GMT+2
Task Type Bug Report
Category ECMAScript
Status Closed
Assigned To Andrew (andrew)
Operating System All
Severity Low
Priority Normal
Reported Version Development
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Script context:
Compare.js#413:

Compare.markDifferences = function(newAndMissingIds) {
...
            entity = Compare.doc1.queryEntity(id);
            entity.setColor(new RColor("green"));
            op = new RModifyObjectOperation(entity.data());
            Compare.di1.applyOperation(op);

ECMA code:

         QScriptValue
        REcmaSharedPointerEntity::setColor
        (QScriptContext* context, QScriptEngine* engine) 
        {
            QScriptValue result = engine->undefinedValue();
                    // public function: can be called from ECMA wrapper of ECMA shell:
                    REntity* self = 
                        getSelf("setColor", context);
=>               Q_ASSERT(self!=NULL);

Stacktrace:

Thread [1] 18673 (Suspended : Signal : SIGABRT:Aborted)	
	__kernel_vsyscall() at 0xffffe424	
	raise() at 0xb4efc8df	
	abort() at 0xb4efe220	
	RMainWindow::messageHandler() at RMainWindow.cpp:63 0x8f3917a	
	qt_message_output() at 0xb5356f65	
	0xb53571ab	
	qFatal() at 0xb53572c9	
	qt_assert() at 0xb5357355	
	REcmaSharedPointerEntity::setColor() at REcmaSharedPointerEntity.cpp:1,360 0x8bc0602	
	0xb6bd813c	
	0xb6ac1f68	
	0xb6a9164c	
	0xa622afd2	
	0xb6a423e3	
	0xb6af06e0	
	0xb6ac201e	
	0xb6be0cd3	
	0xb6be11a9	
	QMetaObject::metacall() at 0xb5478c83	
	QMetaObject::activate() at 0xb5489134	
	<...more frames...>	
This task depends upon

Closed by  Andrew (andrew)
Tuesday, 23 April 2013, 11:38 GMT+2
Reason for closing:  Not a bug

Loading...