QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

Tasklist

FS#1508 - QCAD CE: Subscript and superscript formatting lost when file re-opened

Attached to Project: QCAD
Opened by Daniel Duke (djorlando24) - Wednesday, 07 December 2016, 08:30 GMT+1
Last edited by Andrew (andrew) - Wednesday, 07 December 2016, 09:22 GMT+1
Task Type Bug Report
Category QCAD (main)
Status Closed
Assigned To QCAD Community (QCAD Community)
Operating System Mac OS X (All)
Severity Low
Priority Normal
Reported Version 3.15.5
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When multiple superscripts or subscripts are used in a text field, re-opening the saved dxf file will fail to render all but the first super/subscript element. As per attached example. Bug occurs on all Mac OS X from Mavericks onward.

Minimal reproducible steps:
1. Open new document in QCAD
2. Add a text object
3. Make part of the text sub or super-script
4. Make another part of the text also sub/superscript, with at least one ‘normal’ character between the two sub/superscripts
5. Save file and close it. Don’t have to quit QCAD.
6. Reopen the file. Voila, all but the first sub/superscript element is broken.

Dan.

ps. QCAD is a pretty great piece of software, nice work all.

   before.png (106.1 KiB)
   after.png (137.8 KiB)
This task depends upon

Closed by  Andrew (andrew)
Wednesday, 07 December 2016, 09:22 GMT+1
Reason for closing:  Fixed
Additional comments about closing:  https://github.com/qcad/qcad/commit/0b1b 538f28bff0e99aadf465d995bd18cb4818d7
Comment by Andrew (andrew) - Wednesday, 07 December 2016, 08:34 GMT+1

I cannot reproduce this problem here (using your example text or any other text).
Could you please attach your DXF file? Thanks.

Comment by Andrew (andrew) - Wednesday, 07 December 2016, 08:37 GMT+1

Could it be that you are using the free QCAD Community Edition? I can indeed reproduce a similar problem with that.

Comment by Daniel Duke (djorlando24) - Wednesday, 07 December 2016, 08:42 GMT+1

Yes, indeed I am using the QCAD Community Edition.

Version: 3.15.5.0 (3.15.5)
Internet: QCAD.org
Build Date: Aug 19 2016
Revision: 15ef1a1
Qt Version: 5.5.1
Architecture: x86_64
Compiler: Clang 7.3.0

Comment by Daniel Duke (djorlando24) - Wednesday, 07 December 2016, 19:30 GMT+1

Thanks for committing the fix so fast!

Loading...