QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

Tasklist

FS#1528 - Block attributes: relationship with block reference lost after inserting from library

Attached to Project: QCAD
Opened by jose amaro (joamaro) - Monday, 09 January 2017, 12:59 GMT+1
Last edited by Andrew (andrew) - Tuesday, 10 January 2017, 11:47 GMT+1
Task Type Bug Report
Category QCAD (main)
Status Closed
Assigned To Andrew (andrew)
Operating System All
Severity Low
Priority Normal
Reported Version 3.16.4
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The blocks that are included in drawings by version 3.16.4 do not obey the rule “select attributes along with block references” while in version 3.15.5 in the same drawings and for the same blocks the rule is obeyed.
Note: Blocks already included in the previous version will enforce this rule in the new version.

This task depends upon

Closed by  Andrew (andrew)
Tuesday, 10 January 2017, 11:47 GMT+1
Reason for closing:  Fixed
Comment by jose amaro (joamaro) - Monday, 09 January 2017, 13:03 GMT+1

PS: Windows 10 and Linux Mint

Comment by Andrew (andrew) - Monday, 09 January 2017, 13:04 GMT+1

Thanks for your report.
I cannot reproduce this problem here. Please attach your drawing, thanks.

Comment by jose amaro (joamaro) - Monday, 09 January 2017, 13:39 GMT+1

After you insert the library block and close the file and open it again, the block reference attributes of the first entry in the library disappear;
This does not occur with the following insertions when made through the list of blocks in the drawing but the original layers of the attributes are
not maintained as they are in the library orignally.

Comment by jose amaro (joamaro) - Monday, 09 January 2017, 13:43 GMT+1

Sorry by "my poor english".

Comment by Andrew (andrew) - Monday, 09 January 2017, 14:34 GMT+1

Thanks for the file. Which block from the part library are you inserting? Can you also attach that file? Thanks.

Comment by jose amaro (joamaro) - Monday, 09 January 2017, 19:58 GMT+1

Even though I requested to close this topic I would report that even after the correction in the block attribute structures the error
has occurred and the selection of the attributes along with the block references for the inserts from version 3.16.4 is not working
correctly. It again follows the file with the corrections and a block file as an example.

Comment by Andrew (andrew) - Tuesday, 10 January 2017, 11:44 GMT+1

Thanks. I can reproduce the problem with your file and I can confirm that this will be fixed for the next release.

Loading...