QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

Tasklist

FS#1543 - Input with dead-keys broken (Linux)

Attached to Project: QCAD
Opened by jose amaro (joamaro) - Thursday, 16 February 2017, 13:27 GMT+1
Last edited by Andrew (andrew) - Thursday, 16 February 2017, 19:37 GMT+1
Task Type Bug Report
Category QCAD (main)
Status Closed
Assigned To Andrew (andrew)
Operating System Ubuntu Linux
Severity Low
Priority Normal
Reported Version 3.16.5
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Latin characters do not work in version 3.16.5 on Linux, such as ã, õ, é, à, the curious thing is that “ç-” works. If on your machine the Latin characters that do not work are not appearing follow a bitmap for visualization.

This task depends upon

Closed by  Andrew (andrew)
Thursday, 16 February 2017, 19:37 GMT+1
Reason for closing:  Fixed
Comment by Andrew (andrew) - Thursday, 16 February 2017, 14:09 GMT+1

I cannot reproduce this problem here.
Please attach always the DXF/DWG file you are working with. This will tell us what font you are using, what type of text, etc. thanks.

Comment by jose amaro (joamaro) - Thursday, 16 February 2017, 15:12 GMT+1

The file will not work because the existing files open, show the correct characters, but I can not type new characters in these files or new files.
Sorry.

Comment by Andrew (andrew) - Thursday, 16 February 2017, 15:20 GMT+1

I don't understand, sorry.
Do you mean that the text dialog does not show these characters when you press the appropriate keys? Or the text entity created in the drawing area does not show these characters?
In any case: please submit the DXF file (even if these characters are not visible in it).

Comment by jose amaro (joamaro) - Thursday, 16 February 2017, 17:02 GMT+1

I tested it on two different machines with Linux Mint 18.1 and it is not possible to type Latin characters composed of two keys (symbol + letter) such as "a, ê, õ, ô, etc." but "ç" that is typed By a single key is accepted. This occurs both in the text box and in the Block Attributes box, when the text or attribute is inserted in the drawing appears without the Latin characters; I also noticed that the DXF file created by version 3.15.5 that contains the correct Latin characters sometimes causes QCad 3.16.5 to abort when opened; Follow attachments.

Note: Disregard the file Qcad 3.15.6.desktop

Thanks

Comment by Andrew (andrew) - Thursday, 16 February 2017, 17:55 GMT+1

Can you please extract the attached plugins into your QCAD directory (32bit or 64bit, depending on your platform), so you get a folder "platforminputcontexts" in the QCAD installation directory, same level as "platforms":

qcad-3.16.5-pro-linux-x86_64/platforminputcontexts/libibusplatforminputcontextplugin.so
qcad-3.16.5-pro-linux-x86_64/platforminputcontexts/libcomposeplatforminputcontextplugin.so

This might fix the problem, at least partially. Unfortunately, there are some known issues with Qt, the framework QCAD uses and keyboard input under Linux:

https://bugreports.qt.io/browse/QTBUG-49438 https://bugreports.qt.io/browse/QTBUG-56452

Comment by jose amaro (joamaro) - Thursday, 16 February 2017, 18:49 GMT+1

Problem solved, thank you.

Comment by Andrew (andrew) - Wednesday, 01 March 2017, 11:43 GMT+1

To reproduce:
- install Keyboard layout "German (Switzerland)"
- press Alt-;, then E to produce é

Loading...