QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#1545 - File > Open: Crash on some Linux setups

Attached to Project: QCAD
Opened by jose amaro (joamaro) - Friday, 17 February 2017, 19:16 GMT+2
Last edited by Andrew (andrew) - Thursday, 02 March 2017, 08:32 GMT+2
Task Type Bug Report
Category QCAD (main)
Status Closed
Assigned To Andrew (andrew)
Operating System Ubuntu Linux
Severity Low
Priority Normal
Reported Version 3.16.5
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

A curious fact is occurring here QCad 3.16.5 is aborting the opening of files in 90% of the attempts on a machine with native Linux Mint 18.1 and works normally in a virtual machine under Virtualbox in Windows 10, tests were done on the 3 machines (VM-Linux, Nat-Linux and Win 10) with QCad 3.15.5 and everything works normally. The two notebooks tested have Intel I-7 RAM = 8Gb Ram and 4 processors. Follow 02 files for evaluation.

This task depends upon

Closed by  Andrew (andrew)
Thursday, 02 March 2017, 08:32 GMT+2
Reason for closing:  Fixed
Additional comments about closing:  Fixed by upgrading to Qt 5.8.0
Comment by Andrew (andrew) - Friday, 17 February 2017, 19:26 GMT+2

Can you please check if you are running out of memory while loading the file (using top or similar)?
Also: is this on a 32bit or a 64bit Linux system?

Comment by jose amaro (joamaro) - Friday, 17 February 2017, 19:56 GMT+2

Linux Mint 18.1 64bit (VM and Nat)
I compared the load on Processors and RAM on boot and file opening between 3.15.5 and 3.16.5 and nothing seemed abnormal.

PS: In a very old Acer that I have here QCAD 3.15.5 works very well; 3Gb RAM 1.3KHertz 1 processor

Comment by Andrew (andrew) - Friday, 17 February 2017, 20:04 GMT+2

OK, thanks. Unfortunately, without any further information, it is impossible for use to track down this problem since this is not something we can reproduce here.

A backtrace might be helpful though, if you are terminal savvy:

cd ~/opt/qcad-3.16.5-pro-linux-x86_64
LD_LIBRARY_PATH=. gdb ./qcad-bin
(gdb) run
[QCAD starts, load the file, wait for crash]
(gdb) bt

This will print the stack trace of the last functions called and often point to the area of the problem. If you can, please post the output here, thanks.

Comment by jose amaro (joamaro) - Friday, 17 February 2017, 20:36 GMT+2

OK! I did as indicated however as I had turned off the machine I reboot it and it is now working, the point is that I have worked on this machine for over 6 months as 3.15.x and the problem never happened until I installed 3.16.5; This morning it happened a 10 times and in the afternoon so many and at the time of the test nothing. As soon as it happens again I will repeat the test and report the result.

Comment by jose amaro (joamaro) - Saturday, 18 February 2017, 00:14 GMT+2

Sometimes just terminating the linux session and restarting it is enough so that the program does not abort when opening files.
Now the backtrace with Bug,

Comment by Andrew (andrew) - Wednesday, 01 March 2017, 15:00 GMT+2

Thanks. This looks like a Qt accessibility bug. Unfortunately, I cannot reproduce this here.
However, I've compiled a snapshot package against a newer Qt version (5.8). Could you please check if the problem persists with this snapshot package? I will e-mail the download link to you. Thanks.

Comment by jose amaro (joamaro) - Wednesday, 01 March 2017, 22:11 GMT+2

I tested the package on the machine that presented the problem by opening several files at the same time by closing and restarting QCad, repeating the loading of several drawings and it seems that the problem has been solved.

Thanks

Loading...