QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

Tasklist

FS#1560 - Main menu not selectable (Ubuntu 16.04, Unity)

Attached to Project: QCAD
Opened by Dave Attwood (daibach142) - Monday, 20 March 2017, 22:02 GMT+1
Last edited by Andrew (andrew) - Tuesday, 21 March 2017, 00:05 GMT+1
Task Type Bug Report
Category QCAD (main)
Status Closed
Assigned To Andrew (andrew)
Operating System Ubuntu Linux
Severity High
Priority Normal
Reported Version 3.16.6
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The main menu bar does not allow any selections, there is not even an underscored shortcut character shown.

This task depends upon

Closed by  Andrew (andrew)
Tuesday, 21 March 2017, 00:05 GMT+1
Reason for closing:  Fixed
Additional comments about closing:  https://github.com/qcad/qcad/commit/5ef7 42611a597bd77f9e7f1aeb756609f0111023
Comment by Dave Attwood (daibach142) - Monday, 20 March 2017, 22:05 GMT+1

This is on ubuntu 16.04 (xenial) LTS

Comment by Andrew (andrew) - Monday, 20 March 2017, 22:13 GMT+1

Thanks for your report.

I can confirm that the menu is broken under Ubuntu 16.04. This is likely due to a bug in either Qt 5 or Ubuntu Unity or both. I'll look into possible workarounds.

Comment by Andrew (andrew) - Monday, 20 March 2017, 23:43 GMT+1

A quick fix is now available (file replaces existing file scripts/File/NewFile/NewFile.js in your QCAD installation):
https://raw.githubusercontent.com/qcad/qcad/5ef742611a597bd77f9e7f1aeb756609f0111023/scripts/File/NewFile/NewFile.js

Please let me know if the workaround provides a solution on your installation.

Comment by Dave Attwood (daibach142) - Monday, 20 March 2017, 23:54 GMT+1

Unfortunately, no change. Amazing speed of response, though - thanks.
I'm using 64bit version, running on Intel I5 Skylake processor, ITH.

Comment by Dave Attwood (daibach142) - Tuesday, 21 March 2017, 00:02 GMT+1

Sorry - I think it's fixed by your script (fat fingers here!)
Many thanks

Comment by Andrew (andrew) - Tuesday, 21 March 2017, 00:05 GMT+1

OK, great! Thanks for letting me know.

Loading...