QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

Tasklist

FS#1572 - Dimension font not set to "Standard" when importing through dxflib

Attached to Project: QCAD
Opened by Daniel Duke (djorlando24) - Tuesday, 11 April 2017, 14:20 GMT+1
Last edited by Andrew (andrew) - Monday, 12 June 2017, 10:53 GMT+1
Task Type Bug Report
Category QCAD Community Edition
Status Closed
Assigned To QCAD Community (QCAD Community)
Operating System Mac OS X (All)
Severity Low
Priority Normal
Reported Version 3.16.7
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Since updating to QCAD 3.16 on MacOS, my dimension font face suddenly changed to something very unattractive and I can’t figure out how to reset it. I tried deleting QCAD and all references to it in ~/Library and then reinstalling, but no luck. Something weird has gone wrong with QCAD’s fonts.

The font change has made it impossible to open and redraw many DXF files because the new font face is larger and wider spaced and it ruins the layout of many documents.

Attached is an example of what the same DXF file looked like in the prior QCAD version, and the new version. No change to the DXF file.

Dan.

This task depends upon

Closed by  Andrew (andrew)
Monday, 12 June 2017, 10:53 GMT+1
Reason for closing:  Fixed
Comment by Andrew (andrew) - Tuesday, 11 April 2017, 22:11 GMT+1

The dimension font is stored in the DXF file. Please attach the DXF file you are working on.

Comment by Daniel Duke (djorlando24) - Friday, 14 April 2017, 05:08 GMT+1

sample DXF file attached. QCAD made the file. This is a new bug that recently appeared in macOS. I've done some more investigation in QCAD Pro Trial, and I can reliably reproduce the problem:

1. Fresh install latest version of QCAD (3.16.7) on macOS Sierra 10.12
2. Create a drawing with at least one dimension in it. Font for dimensions looks as it should, no problem yet.
3. Save the drawing as a DXF (in QCAD Pro trial I use R27 format, the first choice)
4. Quit QCAD.
5. Start QCAD again and reopen the DXF file
6. The font has suddenly changed on all the dimensions to something ugly. What's more, the default font is now changed for all new drawings as well. So this is not just a problem of the DXF file, but something breaks in the global QCAD settings after the first time you run the program.

In QCAD Pro Trial I can see what the dimension font is set to. It seems that QCAD keeps overwriting whatever I choose with "Adabi MT Condensed Extra Bold," a disgusting looking font. The reason for this choice is that it is the first font in MacOS by alphabetical order. There seems to be a new bug in QCAD in that when you update the binary, it blows away your dimension font choice and replaces it with the first (alphabetically) font on your system. Since the default setting is being overwritten, the change applies to all new drawings (and even pre-existing drawings)! Reverting to alphabetically first font suggests perhaps a 'font not found' problem - maybe there is a bug/typo that makes QCAD unable to find its default dimension font.

Comment by Daniel Duke (djorlando24) - Friday, 14 April 2017, 05:15 GMT+1

In QCAD Pro, temporary solution is to manually go to drawing settings when reopening any file, and force the dimension font back to what I want it to be.
In QCAD Community edition, the dimension font is not an editable option & there is no workaround.

Loading...