QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#158 - polyline with segment radius mirrored wrong

Attached to Project: QCAD
Opened by Martin (martin) - Friday, 05 August 2011, 16:58 GMT+2
Last edited by Andrew (andrew) - Tuesday, 09 July 2013, 21:08 GMT+2
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System All
Severity Medium
Priority Normal
Reported Version Development
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

  • see attached drawing
This task depends upon

Closed by  Andrew (andrew)
Tuesday, 09 July 2013, 21:08 GMT+2
Reason for closing:  Fixed
Additional comments about closing:  https://github.com/qcad/qcad/commit/0974 59f054533e122c281cf380532bf638524c90
Comment by Leo Potjewijd (LeoP) - Saturday, 29 June 2013, 12:08 GMT+2

... and this is that drawing ...
The problem is visible in the hatchOutline layer (red).
QCAD2 has no problem, QCAD3.1.2 displays wrong.

Comment by Leo Potjewijd (LeoP) - Tuesday, 09 July 2013, 20:54 GMT+2

Problem is still there in some cases, see attached drawing (created by QCAD2)

Comment by Andrew (andrew) - Tuesday, 09 July 2013, 20:56 GMT+2

The problem in demonstration.dxf is with polylines that are scaled with sign(factor x) != sign(factor y). This is often the case for polylines in blocks if a block reference is mirrored when inserted.

Loading...