QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

Tasklist

FS#1606 - Selecting 'Draw Order' halts system temporary

Attached to Project: QCAD
Opened by CVH (CVH) - Wednesday, 28 June 2017, 13:13 GMT+1
Last edited by Andrew (andrew) - Wednesday, 28 June 2017, 22:39 GMT+1
Task Type Performance Issue
Category QCAD (main)
Status Closed
Assigned To Andrew (andrew)
Operating System Windows 7
Severity Low
Priority Normal
Reported Version 3.17.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Merely clicking on ‘Draw Order’, and usualy unintended, halts the system for several seconds up to several tens of seconds.

Intel(R) Core(TM) i7-2600K CPU @ 3.40Ghz
4,00 GB RAM installed 3,49 GB usable
32-bit Operating System
Windows 7 Professional SP1

This task depends upon

Closed by  Andrew (andrew)
Wednesday, 28 June 2017, 22:39 GMT+1
Reason for closing:  Fixed
Comment by Andrew (andrew) - Wednesday, 28 June 2017, 13:45 GMT+1

I cannot reproduce this problem here.

Is this reproducible on your system? I.e. you start QCAD, you click on "Draw Order" in the property editor → System stalls?

If not, your click on "Draw Order" very likely just coincided with a scheduled autosave (see Edit > Application Preferences > Load/Save > Autosave).

Comment by CVH (CVH) - Wednesday, 28 June 2017, 14:27 GMT+1

Reproducible with a bit larger file, not with none (can't) or simple drawings.

Selected an entity, made change to a Specific Property eg. Lenght
Clicked on Draw Order
Click away
System hangs, CPU load max out
system restores after several seconds

Waited 10 counts after an autosave
Grabbed the screen while stalling

Result is the same closing all windows and other applications and unnecessary processes.

Included Grab
Included Drawing file
(Original was not drawn with QCAD)

Comment by Andrew (andrew) - Wednesday, 28 June 2017, 18:08 GMT+1

Thanks. I still cannot quite reproduce that, but I do notice a slight hang (maybe 0.2s) when the focus moves away from the draw order property.

You can find a potential fix at:
https://raw.githubusercontent.com/qcad/qcad/master/scripts/Widgets/PropertyEditor/PropertyEditor.js

This file replaces the file scripts/Widgets/PropertyEditor/PropertyEditor.js in your QCAD installation directory.

Please provide feedback on the potential fix if possible.

Comment by CVH (CVH) - Wednesday, 28 June 2017, 19:58 GMT+1

Replacement by the provided file fixes the problem as far as i can check it for now.
I think you hit the nail on the head.
Regards

Comment by Andrew (andrew) - Wednesday, 28 June 2017, 22:38 GMT+1

OK, great. Thanks!

Loading...