QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

Tasklist

FS#1633 - Scrollbar in dark theme

Attached to Project: QCAD
Opened by Massimo Puglisi (M) - Friday, 22 September 2017, 14:55 GMT+1
Last edited by Andrew (andrew) - Friday, 22 September 2017, 23:15 GMT+1
Task Type Bug Report
Category Themes
Status Closed
Assigned To Andrew (andrew)
Operating System Mac OS X (All)
Severity Low
Priority Low
Reported Version 3.18.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The scrollbar in the dark theme remains visible when there are many levels. For example, it blocks some operations such as unlocking or blocking individual levels after you have blocked all levels.

This task depends upon

Closed by  Andrew (andrew)
Friday, 22 September 2017, 23:15 GMT+1
Reason for closing:  Works for me
Comment by Andrew (andrew) - Friday, 22 September 2017, 15:11 GMT+1

I cannot reproduce this problem here. Please attach your drawing file.

Comment by Massimo Puglisi (M) - Friday, 22 September 2017, 15:21 GMT+1

I attach a sample file to test the bug.

PS
with the default theme all works regularly

Comment by Andrew (andrew) - Friday, 22 September 2017, 16:22 GMT+1

Unfortunately, I still cannot reproduce this problem. Can you indicate the exact procedure needed to reproduce?
Also, please indicate your macOS version. Thanks

Comment by Massimo Puglisi (M) - Friday, 22 September 2017, 17:15 GMT+1

the version of my MAC OS is 10.12.6.

For the procedure:
I have selected the 'block all layers' menu item. Next I wanted to unlock a single level but the scrollbar covered the padlock icon.
Since there is no voice that allows you to block or unlock all other levels except the one selected or in use.

I hope it's all clear.

Comment by Andrew (andrew) - Friday, 22 September 2017, 23:15 GMT+1

Unfortunately, this is not reproducible here on macOS 10.12.6 with QCAD 3.18.0 using the Dark theme which means I won't be able to look into this.
I'll close this for now and re-open if there are any other reports about this.

Loading...