QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

Tasklist

FS#1672 - Dimension tool displays wrong meassurement

Attached to Project: QCAD
Opened by Husky (Husky) - Friday, 01 December 2017, 22:24 GMT+1
Last edited by Andrew (andrew) - Saturday, 02 December 2017, 00:00 GMT+1
Task Type Bug Report
Category QCAD (main)
Status Closed
Assigned To Andrew (andrew)
Operating System Windows 10
Severity Low
Priority Normal
Reported Version 3.19.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Case:
Settings are:
General: Drawing Unit
Drawing Unit: Foot
Paper Unit: Inch
Measurement System: Imperial

Dimension Settings: Architectural

Issue:

I draw a horizontal line 12 units (foot) long,
Use then the Horizontal DIM tool and it will display a measurement of 1’ = false,

I draw a horizontal line of 2 units (foot)long,
Use then the Horizontal DIM tool and it will display a measurement of 2” = false,

I assume the input for the line length is handled from the DIM tool as inch and not as feet.

This task depends upon

Closed by  Andrew (andrew)
Saturday, 02 December 2017, 00:00 GMT+1
Reason for closing:  Not a bug
Comment by Husky (Husky) - Friday, 01 December 2017, 22:52 GMT+1

The Info tool has the same issue.

Comment by Andrew (andrew) - Friday, 01 December 2017, 23:59 GMT+1

Unfortunately, this is expected behavior.

Linear dimension setting "Architectural" implies that the drawing unit is Inch, even if it set to something else (which is also legal).
If Architectural is the desired format, then Inch should be chosen as drawing unit, if not the result is a mess.
This is all for the sake of compatibility. Strictly speaking (historically), there is of course no drawing unit in CAD, but if the linear format is Architectural or Engineering, the unit is implicitly assumed to be Inch.

BTW: one can still enter measurements in Feet (2', 4', 2'-3", 2'-3 1/2", etc.).

Comment by Andrew (andrew) - Saturday, 02 December 2017, 00:09 GMT+1

I've made the preferences dialog more restrictive when choosing these formats. But it will still be possible to load drawings with conflicting settings.

Comment by Husky (Husky) - Saturday, 02 December 2017, 04:11 GMT+1

Ok, understood. Thanks for explanation!

I've made the preferences dialog more restrictive when choosing these formats. But it will still be possible to load drawings with conflicting settings.«

Good idea. ;-)

Comment by Husky (Husky) - Saturday, 02 December 2017, 20:47 GMT+1

Hmmm - that effects Meta Grid Spacing too? I can't set a Meta Grid less than 1" by 1"? :-(
Normal Grid spacing works just fine.

Loading...