QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

Tasklist

FS#1688 - Scaling (SZ) selection by Mouse only proportional possible

Attached to Project: QCAD
Opened by Husky (Husky) - Tuesday, 26 December 2017, 21:56 GMT+2
Last edited by Andrew (andrew) - Thursday, 28 December 2017, 13:17 GMT+2
Task Type Bug Report
Category QCAD (main)
Status Closed
Assigned To Andrew (andrew)
Operating System All
Severity Low
Priority Normal
Reported Version 3.19.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Tested with checked / unchecked button for proportional scaling - but it doesn’t matter.

This task depends upon

Closed by  Andrew (andrew)
Thursday, 28 December 2017, 13:17 GMT+2
Reason for closing:  Not a bug
Additional comments about closing:  Expected behaviour
Comment by Andrew (andrew) - Thursday, 28 December 2017, 13:17 GMT+2

This is expected behaviour. Scaling with the mouse relies on the user clicking two points with different distances to the focus point. This would not work with unproportional scaling. Note that the proportional scaling button has no effect (grayed out) when the mouse cursor button is checked.

Comment by Husky (Husky) - Thursday, 28 December 2017, 22:31 GMT+2

Ok, I understood that this is currently expected behavior. Thanks for the info.

Question:

This would not work with unproportional scaling«

Unproportional scaling without mouse works perfect - just choose the Focus Point and put e.g. Factor X = 1.2, Factor Y = 1.8 in and it is done. Easy .... if you know what you need for x and y ...

I faced now many time a situation like my example - to solve this it needs a lot of extra work to get the task precisely done. I thought it shout be possible with the "Scaling with mouse" function if that tool would be able to read and calculate the x / y distance from the Focus Point(1) / Reference Point(2) / Target Point(3).

Try to accomplish the given / goal task in the dxf to see how many steps are necessary. If it makes sense to you please change this report to a feature request. Thanks.

Loading...