QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help > Check for Updates)

Tasklist

FS#1717 - small fix in startup script

Attached to Project: QCAD
Opened by Timofey V. Chernyshev (thambs) - Tuesday, 13 February 2018, 23:25 GMT+2
Last edited by Andrew (andrew) - Thursday, 22 March 2018, 12:03 GMT+2
Task Type Bug Report
Category QCAD (main)
Status Closed
Assigned To Andrew (andrew)
Operating System Linux (All / Other)
Severity Low
Priority Normal
Reported Version 3.19.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

The current startup script fails when called through symbolic link due to string:

DIR=${0%/*}

It is better to change it to:

DIR=$(dirname -- $(readlink -f -- $0))
This task depends upon

Closed by  Andrew (andrew)
Thursday, 22 March 2018, 12:03 GMT+2
Reason for closing:  Not a bug
Comment by Andrew (andrew) - Tuesday, 13 March 2018, 14:42 GMT+2

readlink has other problems (non-standard, see http://mywiki.wooledge.org/BashFAQ/028)

Using PWD would very likely break existing use cases.

For now, we're moving to BASH_SOURCE which is also not perfect but seems to cover most use cases and assures backwards compatibility.

Feel free to comment..

Loading...