QCAD Bugtracker

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category QCAD (main)
  • Assigned To
    Andrew
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version 3.20.1
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: QCAD Bugtracker
Opened by CVH - 18.05.2018
Last edited by Andrew - 18.05.2018

FS#1757 - Modify > Auto Trim: on polyline, followed by undo yields corrupt / invisible polyline

Breaking up self-intersecting Polys at segments crossing
can’t be done for the second segment.

Divide:
A new node is inserted and made start and end node.
For the second segment no division occurs or can be made.
Expected is that the segment the nearest to the selecting point is addressed.
Eg. the trim command.

Breakout gap:
- 1 Part fully trimmend of
- Can be undone

Auto trim:
(hint: do file-save first to revert)
- 1 Part fully trimmend of
- Undo will wipe the complete poly

In the file example 1.

Work-arround:
- Divide
- Insert node on the second segment not at the crossing
- Divide at that node
- Move new nodes to crossing

QCAD 3.20.1 Win7 32bit
Kind Regards

Closed by  Andrew
18.05.2018 11:16
Reason for closing:  Fixed
Additional comments about closing:  

https://github.com/qcad/qcad/commit /9f0118f8ab0b63d14879789b530f154a6ca277f 3

Admin
Andrew commented on 18.05.2018 11:14

Please post one report per problem. I'm unable to identify how many problems this report is about.

I've fixed the problem I was able to reproduce here and changed the title accordingly.

CVH commented on 18.05.2018 11:26

Just one
I tried 3 methods
the tirth can't be undone

Thanks

CVH commented on 19.05.2018 21:25

I will try this in a new release so I can see what method was addressed.
Re-entered the first more elaborated because I didn't mentioned undo there.
Regards

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing