QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#199 - Print preview scaling distorts model view

Attached to Project: QCAD
Opened by Peter (hungerburg) - Friday, 26 August 2011, 20:47 GMT+2
Last edited by Andrew (andrew) - Wednesday, 07 September 2011, 10:56 GMT+2
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System All
Severity Medium
Priority Normal
Reported Version Development
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

- Draw a rectangle, say 100 x 100 (I use mm unit, but does it matter?)
1
- Turn on print preview
- Turn off print preview
- OK
2
- Turn on print preview
- Set scale 1/10
- Lines are thicker now, this is good
- Turn off print previw
- Lines stay thick in model view, should that be so?
3
- Set layer 0 to use dash as line-style
- Turn on print preview
- Looks OK
- Set scale 1/10
- Dashes hardly visible, looks almost like a continuous line

In the end of 2,3 a way to reset line width display in model view is to cancel scaling in print preview, ie. turn on print preview, set scale 1:1. I suppose this is a regression since TP1: model view always is unscaled.

The line-width scaling is quite accurate now: Draw two lines 10 mm apart. Set line-width 0.5mm. Set scale 1:20 and the lines exactly touch.

This task depends upon

Closed by  Andrew (andrew)
Wednesday, 07 September 2011, 10:56 GMT+2
Reason for closing:  Fixed
Additional comments about closing:  r18974

Loading...