QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#234 - File completely erased/corrupted; then duplicates upon loading with 1 blank,1 blue line version.

Attached to Project: QCAD
Opened by Bob (bwallum) - Saturday, 03 September 2011, 21:14 GMT
Last edited by Andrew (andrew) - Monday, 05 September 2011, 15:49 GMT
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System Ubuntu Linux
Severity High
Priority Normal
Reported Version 3 Beta
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I have been working with a file in 2.2 which I then opened with beta 3. All seemed to be well for a couple of days. Today the application closed itself. When I restarted and tried to load the file it came up duplicated. One tab showed nothing, the other showed my drawing with blue lines and the tab headers (file name) were identical except that the ‘blue line’ tab had an asterisk after the file name indicating that the file had been changed. Highlighting a ‘blue line’ element showed the properties with colour white.

I’m running 64bit Ubuntu 11.04. ‘Blue line’ file attached. Any quick way to change the blue lines to default white?

This task depends upon

Closed by  Andrew (andrew)
Monday, 05 September 2011, 15:49 GMT
Reason for closing:  Not a bug
Additional comments about closing:  The color change is very likely not a software bug but a usage problem.

The application closing itself sounds like a bug, but not enough information is provided to fix it.
Comment by Bob (bwallum) - Sunday, 04 September 2011, 10:13 GMT

I can use Select All with all layers visible to restate white lines in Properties. However blocks are not changed so each block needs to be dealt with seperately. I now appear to have a fully recovered file showing white lines on my screen.

Comment by Andrew (andrew) - Monday, 05 September 2011, 15:47 GMT

All colors in your drawing are defined 'ByLayer'. This means that the entities inherit their color from the layer they are on.
As they appear to be on layer 'Liner', change the color of layer 'Liner' from blue to white:

1. Make sure the layer list is visible:

  1. View - Toolbars - Layer List

2. Right-click on layer 'Liner' in the layer list
3. From the context menu, choose 'Edit Layer'
4. Change color to 'white' and click OK

Loading...