QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#286 - mutex lock failed

Attached to Project: QCAD
Opened by Stefan (stefan) - Friday, 30 September 2011, 16:50 GMT+2
Last edited by Andrew (andrew) - Friday, 30 September 2011, 20:43 GMT+2
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System Ubuntu Linux
Severity High
Priority Normal
Reported Version 3 Beta 2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Starting qcad 3 beta 2 under xubuntu 10.04, there are several warnings and debug messages. The “mutex lock failed” seems to be worth reported.

Complete console output:

#77-Ubuntu SMP Tue Sep 13 19:40:53 UTC 2011
i686
application directory:  "/home/smf/qcad-3.0.0-beta2-trial-linux" 
working path:  "/home/smf/qcad-3.0.0-beta2-trial-linux" 
library path:  "/home/smf/qcad-3.0.0-beta2-trial-linux/plugins" 
Debug:    Init script plugins... 
Debug:    TIMER:  1424 ms -  "loading and initializing plugins" 
Warning:  RScriptHandlerEcma::doScript: engine busy: aborting evaluation of script: 

 "scripts/File/NewFile/NewFile.js" 

 
Warning:  QScriptEngine::newVariant(): changing class of non-QScriptObject not supported
Debug:    Creating storage... 
Debug:    Creating spatial index... 
Debug:    Creating document... 
Debug:    Creating MDI child... 
Debug:    Initialize Viewports... 
Debug:    Init graphics view... 
Debug:    Init scrollbars... 
Debug:    Init rulers... 
Debug:    Init idle and default actions... 
Warning:  QScriptEngine::newVariant(): changing class of non-QScriptObject not supported
Debug:    RDocumentInterface::deleteTerminatedActions: mutex lock failed 
Debug:    lock failed:  "EACTION FINISH: scripts/Snap/Auto/Auto.js" 
Debug:    locker:  "NEW" 
Debug:    lock failed:  "EACTION RESUME: scripts/Idle/Reset/Reset.js" 
Debug:    locker:  "NEW" 
Warning:  QScriptEngine::newVariant(): changing class of non-QScriptObject not supported
Debug:    RDocumentInterface::deleteTerminatedActions: mutex lock failed 
Debug:    lock failed:  "EACTION FINISH: scripts/Snap/RestrictOff/RestrictOff.js" 
Debug:    locker:  "NEW" 
Debug:    lock failed:  "EACTION RESUME: scripts/Idle/Reset/Reset.js" 
Debug:    locker:  "NEW" 
Debug:    Show MDI child... 
Debug:    lock failed:  "RMainWindowQt::subWindowActivated" 
Debug:    locker:  "NEW" 
Debug:    Init event handler... 
Debug:    updateScenes... 
Debug:    updateGuiActions... 
Debug:    notifyListenersSlot... 
Warning:  QScriptEngine::newVariant(): changing class of non-QScriptObject not supported
Debug:    RDocumentInterface::deleteTerminatedActions: mutex lock failed 
Warning:  QScriptEngine::newVariant(): changing class of non-QScriptObject not supported
Debug:    RDocumentInterface::deleteTerminatedActions: mutex lock failed 
Debug:    setActiveSubwindow... 
Warning:  QScriptEngine::newVariant(): changing class of non-QScriptObject not supported
Debug:    RDocumentInterface::deleteTerminatedActions: mutex lock failed 
Warning:  QScriptEngine::newVariant(): changing class of non-QScriptObject not supported
Debug:    RDocumentInterface::deleteTerminatedActions: mutex lock failed 
Debug:    lock failed:  "EACTION FINISH: scripts/Idle/Reset/Reset.js" 
Debug:    locker:  "RMdiChildQt::closeEvent" 
Warning:  QMainWindow::saveState(): 'objectName' not set for QDockWidget 0xc0a1be0 'Trial;
Debug:    lock failed:  "RMainWindowQt::subWindowActivated" 
Debug:    locker:  "RMainWindowQt::closeEvent" 
Debug:    autostart.js: main(): end. 
This task depends upon

Closed by  Andrew (andrew)
Friday, 30 September 2011, 20:43 GMT+2
Reason for closing:  Not a bug

Loading...