QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#319 - Prints as though A4 even though I change paper size in both Preferences/page and Print/Properties

Attached to Project: QCAD
Opened by Anonymous Submitter - Sunday, 16 October 2011, 16:24 GMT+2
Last edited by Andrew (andrew) - Monday, 24 October 2011, 12:31 GMT+2
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System OpenSUSE Linux
Severity Medium
Priority Normal
Reported Version 3 Beta 2
Due in Version 3.0.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

This continues a problem that occurred in Qcad 2.2/OpenSuse 11.1:

1. The default paper size is always A4. (minor, but annoying)

2. Here is the serious problem: When I change the paper size to, for example tabloid, in File/Drawing Preferences/Page and in Print/Properties, the print job prints as though it were A4. This occurs unless I first go to Yast or Control Center and (as superuser) change the default page size. Other programs (such as Open Office) don’t require this.

The printer is an HP deskjet 9800, and the problem occurs with either CUPS or hplip printing.

I am using Opensuse 11.3 (I haven’t been able to install successfully opensuse 11.4 on my computer), Qcad
Version:
3.0 Beta 2
Date:
Sep 17 2011
Qt Version:
4.7.3
Edition:
Full Version

This task depends upon

Closed by  Andrew (andrew)
Monday, 24 October 2011, 12:31 GMT+2
Reason for closing:  Fixed
Additional comments about closing:  1. fixed
2. can't be fixed
Comment by Andrew (andrew) - Sunday, 16 October 2011, 17:03 GMT+2

Does PDF export to alternative paper sizes work as expected? Thanks.

Comment by Shannon T. Hunter (Juanito) - Sunday, 16 October 2011, 18:00 GMT+2

The PDF export works correctly.

SVG export gives an odd paper size, but will print correctly on tabloid.

Comment by Andrew (andrew) - Monday, 17 October 2011, 21:02 GMT+2

QCAD uses exactly the same code for PDF export as for printing which tells me that the problem is somewhere outside the scope of QCAD (possibly Qt).

There's a related Qt bug that might be interesting:
https://bugreports.qt.nokia.com//browse/QTBUG-6468

Apparently, the printer dialog under Linux lets you change the paper size in two places - maybe you could try to adjust it in both places and see if that changes anything.

Otherwise, I recommend to go the route over PDF for now if possible.

The default paper size being A4 is a bug and will be fixed.

Comment by Andrew (andrew) - Monday, 24 October 2011, 20:38 GMT+2

Another possibly related Qt bug:
https://bugreports.qt.nokia.com/browse/QTBUG-8619

Loading...