QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#342 - SIGPIPE QPrinter::init()

Attached to Project: QCAD
Opened by Martin (martin) - Friday, 28 October 2011, 11:43 GMT
Last edited by Andrew (andrew) - Friday, 28 October 2011, 12:32 GMT
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System OpenSUSE Linux
Severity Medium
Priority Normal
Reported Version 3 Beta 3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

  • tried different options in print preview (auto scale, auto fit etc.)
Thread [1] 18993 (Suspended : Signal : SIGPIPE:Broken pipe)	
	__kernel_vsyscall() at 0xffffe424	
	send() at 0xb517d5b8	
	0xacd3d8b2	
	httpFlushWrite() at 0xacd3dc21	
	0xacd3fcb8	
	cupsSendRequest() at 0xacd56470	
	cupsDoIORequest() at 0xacd56bc7	
	cupsDoRequest() at 0xacd56f0b	
	0xacd35d7f	
	cupsGetDests2() at 0xacd375d5	
	cupsGetDests() at 0xacd379a3	
	0xb5ad5153	
	0xb5a12133	
	0xb5a28344	
	0xb5a2b78c	
	QPrinter::init() at 0xb5a2d4ee	
	QPrinter::QPrinter() at 0xb5a2f01f	
	QtScriptShell_QPrinter::QtScriptShell_QPrinter() at 0xb02c9e29	
	qtscript_QPrinter_static_call() at 0xafe863ba	
	0xb6bd7f88	
	0xb6ac7c97	
	0xb6a91114	
	0xa95f7580	
	0xb6a44262	
	0xb6a445f7	
	0xb6bb0f92	
	QScriptEngine::evaluate() at 0xb6bba46f	
	RScriptHandlerEcma::ecmaInclude() at RScriptHandlerEcma.cpp:1,051 0x87d5f9d	
	0xb6bd813c	
	0xb6ac1f68	
	0xb6a9164c	
	0xa970b87d	
	0xb6a44262	
	0xb6a445f7	
	0xb6bb0f92	
	QScriptEngine::evaluate() at 0xb6bba46f	
	RScriptHandlerEcma::ecmaInclude() at RScriptHandlerEcma.cpp:1,051 0x87d5f9d	
	0xb6bd813c	
	0xb6ac1f68	
	0xb6a9164c	
	0xa9717387	
	0xb6a44262	
	0xb6a445f7	
	0xb6bb0f92	
	QScriptEngine::evaluate() at 0xb6bba46f	
	RScriptHandlerEcma::eval() at RScriptHandlerEcma.cpp:786 0x87d4014	
	RScriptHandlerEcma::doScript() at RScriptHandlerEcma.cpp:782 0x87d3ef8	
	RScriptHandlerEcma::createActionDocumentLevel() at RScriptHandlerEcma.cpp:873 0x87d4677	
	RGuiAction::slotTrigger() at RGuiAction.cpp:628 0x8f7a23c	
	RGuiAction::qt_metacall() at moc_RGuiAction.cpp:86 0x8fc60a9	
	QMetaObject::metacall() at 0xb5478c83	
	QMetaObject::activate() at 0xb5489134	
	QAction::triggered() at 0xb5869d99	
	QAction::activate() at 0xb586b48f	
	QToolButton::nextCheckState() at 0xb5da52b2	
	0xb5cbb61f	
	QAbstractButton::mouseReleaseEvent() at 0xb5cbb8dc	
	QToolButton::mouseReleaseEvent() at 0xb5da53ac	
	QWidget::event() at 0xb58da629	
	QAbstractButton::event() at 0xb5cba7bf	
	QToolButton::event() at 0xb5da82ae	
	QApplicationPrivate::notify_helper() at 0xb5871d7c	
	QApplication::notify() at 0xb58772c4	
	QCoreApplication::notifyInternal() at 0xb547215b	
	QApplicationPrivate::sendMouseEvent() at 0xb5875152	
	0xb59066b5	
	QApplication::x11ProcessEvent() at 0xb5905d26	
	0xb5932f04	
	g_main_context_dispatch() at 0xb4aee509	
	0xb4aeed10	
	g_main_context_iteration() at 0xb4aeefce	
	QEventDispatcherGlib::processEvents() at 0xb54a2741	
	0xb5932a55	
	QEventLoop::processEvents() at 0xb547131d	
	QEventLoop::exec() at 0xb54715aa	
	QCoreApplication::exec() at 0xb5473701	
	qtscript_QCoreApplication_static_call() at 0xb08dc4b7	
	0xb6bd813c	
	0xb6ac1f68	
	0xb6a9164c	
	0xb100cf6b	
	0xb6a44262	
	0xb6a445f7	
	0xb6bb0f92	
	QScriptEngine::evaluate() at 0xb6bba46f	
	RScriptHandlerEcma::eval() at RScriptHandlerEcma.cpp:786 0x87d4014	
	RScriptHandlerEcma::doScript() at RScriptHandlerEcma.cpp:782 0x87d3ef8	
	RScriptHandler::init() at RScriptHandler.cpp:31 0x8fa7476	
	main() at main.cpp:228 0x87cd9c9	
This task depends upon

Closed by  Andrew (andrew)
Friday, 28 October 2011, 12:32 GMT
Reason for closing:  Not a bug
Additional comments about closing:  this should not be possible in release mode as we catch the signal SIGPIPE
Comment by Andrew (andrew) - Friday, 28 October 2011, 12:29 GMT

could be that gdb catches the signal before we do.

Loading...