QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#368 - Appearance preference

Attached to Project: QCAD
Opened by Peter (hungerburg) - Saturday, 05 November 2011, 13:08 GMT+2
Last edited by Andrew (andrew) - Monday, 07 November 2011, 20:23 GMT+2
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System All
Severity Low
Priority Normal
Reported Version 3 RC1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

RC1 is lazy in saving appearance to config. I noticed, because it always started with default window size. Maximizing was not carried over, also the panels were consistently reset.

Only when eg. dragging the handle to change cad-toolbar width not from preferences it would write an “appearance” section to the config file.

The appearance section should be written rather sooner than later.

This task depends upon

Closed by  Andrew (andrew)
Monday, 07 November 2011, 20:23 GMT+2
Reason for closing:  Not a bug
Comment by Andrew (andrew) - Saturday, 05 November 2011, 20:39 GMT+2

Apearance (window size, position, panels, etc.) are saved on exit. Could it be that QCAD did not terminate properly (e.g. crash or Ctrl-C in terminal)?

Comment by Peter (hungerburg) - Sunday, 06 November 2011, 00:12 GMT+2

I often "quit" from the terminal so it may well be, that this was it, as this will produce such a short config.file. Not doing so in fact includes appearance. so please close.

Because you mention that, I want to tell, crashes have been very rare from tp1 on and disappeared at all in more recent versions.

Loading...