QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#380 - Destroying cross-hatch

Attached to Project: QCAD
Opened by Ralf Braumann (LuxRalf) - Wednesday, 09 November 2011, 16:04 GMT
Last edited by Andrew (andrew) - Monday, 14 November 2011, 11:02 GMT
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System Windows 7
Severity Medium
Priority Normal
Reported Version 3 RC1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

By saving a drawing QCAD is destroying the cross-hatches

This task depends upon

Closed by  Andrew (andrew)
Monday, 14 November 2011, 11:02 GMT
Reason for closing:  Fixed
Additional comments about closing:  r19669
Comment by Andrew (andrew) - Wednesday, 09 November 2011, 18:27 GMT

- What hatch pattern do you use?
- Do you create the drawing in QCAD or load an existing drawing (in the latter case, please attach or send by e-mail to info@ribbonsoft.com)
- Please make sure you are not in draft mode in which hatches are not displayed (View - Draft Mode)

Comment by Lothar Marzahn (Malok) - Thursday, 10 November 2011, 15:01 GMT

It's the same for MAC Lion, Solid fill is not stored or reloaded

Comment by Andrew (andrew) - Thursday, 10 November 2011, 15:24 GMT

Lothar Marzahn:
I cannot reproduce the problem here.

Please send drawings for testing if possible.

Otherwise, please explain what shapes you are filling, i.e. how to reproduce the problem. Thanks.

Comment by Lothar Marzahn (Malok) - Thursday, 10 November 2011, 21:47 GMT

A testfile with a filled rectangle containing a circle and some arcs and lines was stored and reloaded. It worked!! But at the attached file hatch failed but works in QCAD2.
Loading it from QCAD2 the hatch is shown, but store and reload in QCAD3 the hatch is gone.

   test2.dxf (261.8 KiB)
Comment by Andrew (andrew) - Saturday, 12 November 2011, 09:36 GMT

The hatches in the file have no boundary.

Is the attached file the file you have already saved in QCAD 3?
Do you still have the original file? That would be more helpful, thanks.

Comment by Lothar Marzahn (Malok) - Saturday, 12 November 2011, 17:42 GMT

I send a set of files. "LM2-test1" is a file created and modified by QCAD2. "LM3-test1" is the same file only viewed by QCAD3 and will so far show the same picture. But if You save it with QCAD3 the hatch is away and even QCAD2 will not find it.
"LM-test2" is a file that works regardless of the QCAD-version! I hope it will help.

Comment by Lothar Marzahn (Malok) - Sunday, 13 November 2011, 20:25 GMT

I send one more file. For the time being the problem seems to be related to arcs because simple boxes and circles don't create problems. The shape in the attached file worked fine from the beginning with arcs rotating in the same direction. First when I entered the arcs in the red circled region the hatch was no longer stored. In order to verify this I went back to the previos shape. But from this moment already one arc caused the problem! May be, there is also something stored witch is confusing the program.

Comment by Andrew (andrew) - Monday, 14 November 2011, 10:59 GMT

Thanks. The problem has been identified (wrong angles with reversed arcs) and fixed for the next release.

Loading...