QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#406 - QCAD Version 3 RC2 .exe does`nt run

Attached to Project: QCAD
Opened by -- (clive) - Saturday, 26 November 2011, 10:08 GMT+1
Last edited by Andrew (andrew) - Wednesday, 30 November 2011, 00:26 GMT+1
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System Windows 7
Severity High
Priority Normal
Reported Version 3 RC1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi Andrew

I uninstalled QCAD 3 RC1 first then installed V3-RC2 seems to install ok but when I run qcad.exe it complains everytime that qcad.exe has stopped working!

Running on Windows 7 - 64bit

Regards

Clive

This task depends upon

Closed by  Andrew (andrew)
Wednesday, 30 November 2011, 00:26 GMT+1
Reason for closing:  Fixed
Additional comments about closing:  Release: QCAD 3 RC3 for Windows
Comment by Husky (Husky) - Sunday, 27 November 2011, 10:02 GMT+1

I have the same problem under XP/32bit except that I kept 3RC1 and installed 3RC2 in a new subdirectory.

During program start:
"qcad.exe hat ein Problem festgestellt und muss beendet werden"

Problemsignatur:
AppName: qcad.exe AppVer: 0.0.0.0 ModName: qtcore4.dll
ModVer: 4.7.3.0 Offset: 000e7ea3

Comment by -- (clive) - Sunday, 27 November 2011, 15:00 GMT+1

Thanks Husky

I have installed 3RC2 to a new subdirectory as you suggested and all is working fine now!

Regards

Clive

Comment by Andrew (andrew) - Sunday, 27 November 2011, 20:09 GMT+1

Sometimes reproducible. Seems to be caused partly by stored value in Appearance/DockappWindows.

Changing in autostart.js

appWin.readSettings();
appWin.show();

to

appWin.show();
appWin.readSettings();

seems to fix it.
Possibly a Qt bug.

An RC2b package with the above fix will be available shortly.

Comment by Andrew (andrew) - Sunday, 27 November 2011, 20:24 GMT+1

A potential fix is now online as RC2b. Please let me know if it does not work.

Comment by Husky (Husky) - Sunday, 27 November 2011, 22:35 GMT+1

Nope - also RC2b doesn't work on my machine. Still a problem with the qtcore4.dll

Comment by Andrew (andrew) - Sunday, 27 November 2011, 22:49 GMT+1

Please attach your QCAD.ini file:
C:\Documents and Settings\username\Application Data\RibbonSoft\QCAD3.ini

Where 'username' is your user (login) name. The exact path might depend on your system.

Bitte QCAD.ini Datei anhaengen:
C:\Documents and Settings\username\Application Data\RibbonSoft\QCAD3.ini

Wo 'username' Ihr Benutzername ist. Der Pfad kann von System zu System unterschiedlich sein.

Comment by Husky (Husky) - Sunday, 27 November 2011, 23:53 GMT+1

Already in your inbox at info@ ......

Comment by Andrew (andrew) - Monday, 28 November 2011, 01:21 GMT+1

Thanks.

This seems to be related to user defined commands / shortcuts stored in the QCAD3.ini file.

At least deleting sections [Shortcuts] and [Commands] avoids the crash here.

I will continue to look into this.

Comment by Husky (Husky) - Monday, 28 November 2011, 08:19 GMT+1

Step 1:
After this hint from you I went back to RC1 and "restored to default" the two Shortcuts what I have changed in RC1. Note: I never deleted a Shortcut or Command.
Now RC2 is starting as expected - now crash!

Step 2:
I changed two shortcuts in RC2, saved the changes, restarted RC2 and was still able to start RC2 as normal.

It seems that you are on the right way ....

Comment by Jean-Jacques Brasse (J-J) - Monday, 28 November 2011, 10:32 GMT+1

installed RC2b. So far I did not notice the previous problems after editing the config file.
Thanks

Comment by -- (clive) - Monday, 28 November 2011, 19:58 GMT+1

Hi Andrew

RC2b installed and working fine now - no problems.

regards

Clive

Loading...