QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#410 - Grid preferred before enteties

Attached to Project: QCAD
Opened by Ralf Braumann (LuxRalf) - Tuesday, 29 November 2011, 19:37 GMT+1
Last edited by Andrew (andrew) - Tuesday, 29 November 2011, 21:26 GMT+1
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System Windows 7
Severity Medium
Priority Normal
Reported Version 3 RC2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When I want to select in example a intersection or a endpoint, QCAD v3RC2 preferred to choose the grid not the intersection or the endpoint of enteties.

This task depends upon

Closed by  Andrew (andrew)
Tuesday, 29 November 2011, 21:26 GMT+1
Reason for closing:  Fixed
Additional comments about closing:  r19864
Comment by -- (clive) - Tuesday, 29 November 2011, 20:10 GMT+1

Hi LuxRalf

I haven`t found that happening in RC2 yet! But when presented with the snap options you should be able to select the snap mode of your choice.

Regards

Clive

Comment by -- (clive) - Tuesday, 29 November 2011, 20:28 GMT+1

Hi LuxRalf

Sorry - what I meant was that if you find this happening its probably because the last snap choice is remembered, so what you do is choose the snap mode of your choice. I hope this makes sense to you!

Clive

Comment by Andrew (andrew) - Tuesday, 29 November 2011, 21:02 GMT+1

I can confirm the bug.

It happens if auto snap is on and a grid point is closer to the mouse cursor that an intersection point but both points are within the snap range. This is caused by an optimization introduced in RC2 and will be fixed in RC3.

Comment by Ralf Braumann (LuxRalf) - Wednesday, 30 November 2011, 19:19 GMT+1

Click "snap" → "Auto" one time and all is good for the moment. But at the next choice it is "snapping" the grid again.
When you fix it in RC3 all is OK

Loading...