QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#415 - SEGFAULT RMainWindowQt::event(), add custom property to block reference

Attached to Project: QCAD
Opened by Martin (martin) - Thursday, 01 December 2011, 15:13 GMT+1
Last edited by Andrew (andrew) - Wednesday, 22 May 2013, 16:04 GMT+1
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System OpenSUSE Linux
Severity Very Low
Priority Low
Reported Version Development
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

  • SEGFAULT when trying to add custom string property to a block reference

back trace:

Thread [1] 5622 (Suspended : Signal : SIGSEGV:Segmentation fault)	
	malloc_consolidate() at 0xb50470e8	
	_int_malloc() at 0xb5048743	
	_int_realloc() at 0xb504a2d3	
	realloc() at 0xb504bbd3	
	qRealloc() at 0xb535a864	
	QVectorData::reallocate() at 0xb53c78ac	
	0xb58ddc9f	
	0xb5a3f96e	
	0xb5a361fd	
	0xb5a3989f	
	0xb5a39b1a	
	QRegion::operator+=() at 0xb5a3b283	
	0xb5acf62c	
	QWidgetPrivate::syncBackingStore() at 0xb58ca7e2	
	QWidget::event() at 0xb58daf74	
	QMainWindow::event() at 0xb5d2c6d5	
	RMainWindowQt::event() at RMainWindowQt.cpp:624 0x8e86f7d	
	QApplicationPrivate::notify_helper() at 0xb5871d7c	
	QApplication::notify() at 0xb5875b64	
	QCoreApplication::notifyInternal() at 0xb547215b	
	QCoreApplicationPrivate::sendPostedEvents() at 0xb5473457	
	QCoreApplication::sendPostedEvents() at 0xb547363d	
	0xb54a2344	
	g_main_context_dispatch() at 0xb4aee509	
	0xb4aeed10	
	g_main_context_iteration() at 0xb4aeefce	
	QEventDispatcherGlib::processEvents() at 0xb54a2741	
	0xb5932a55	
	QCoreApplication::processEvents() at 0xb54738e9	
	0xb6930965	
	QScriptEngineAgentPrivate::atStatement() at 0xb6bc297b	
	0xb6a41232	
	0xb6a8d39a	
	0xaa2d721d	
	0xb6a423e3	
	0xb6af06e0	
	0xb6ac201e	
	QScriptValue::call() at 0xb6bd2e67	
	REcmaShellPropertyEditor::updateGui() at REcmaShellPropertyEditor.cpp:1,183 0x8d3b975	
	RPropertyEditor::updateFromDocument() at RPropertyEditor.cpp:226 0x8fb3f7d	
	REcmaShellPropertyEditor::updateFromDocument() at REcmaShellPropertyEditor.cpp:111 0x8d370ba	
	RMainWindow::notifyPropertyListeners() at RMainWindow.cpp:245 0x8f9de71	
	RMainWindowQt::event() at RMainWindowQt.cpp:568 0x8e86eb7	
	QApplicationPrivate::notify_helper() at 0xb5871d7c	
	QApplication::notify() at 0xb5875b64	
	QCoreApplication::notifyInternal() at 0xb547215b	
	QCoreApplicationPrivate::sendPostedEvents() at 0xb5473457	
	QCoreApplication::sendPostedEvents() at 0xb547363d	
	0xb54a2344	
	g_main_context_dispatch() at 0xb4aee509	
	0xb4aeed10	
	g_main_context_iteration() at 0xb4aeefce	
	QEventDispatcherGlib::processEvents() at 0xb54a2741	
	0xb5932a55	
	QEventLoop::processEvents() at 0xb547131d	
	QEventLoop::exec() at 0xb54715aa	
	QCoreApplication::exec() at 0xb5473701	
	qtscript_QCoreApplication_static_call() at 0xb08dc4b7	
	0xb6bd813c	
	0xb6ac1f68	
	0xb6a9164c	
	0xb083e0f4	
	0xb6a44262	
	0xb6a445f7	
	0xb6bb0f92	
	QScriptEngine::evaluate() at 0xb6bba46f	
	RScriptHandlerEcma::eval() at RScriptHandlerEcma.cpp:790 0x87d5a26	
	RScriptHandlerEcma::doScript() at RScriptHandlerEcma.cpp:786 0x87d591f	
	RScriptHandler::init() at RScriptHandler.cpp:31 0x8fbbbc2	
	main() at main.cpp:256 0x87cf40a	

This task depends upon

Closed by  Andrew (andrew)
Wednesday, 22 May 2013, 16:04 GMT+1
Reason for closing:  Fixed
Additional comments about closing:  Likely caused by script debugger
Comment by Martin (martin) - Thursday, 01 December 2011, 15:17 GMT+1

reproducible, but error differs:

Thread [1] 5996 (Suspended : Signal : SIGABRT:Aborted)	
	__kernel_vsyscall() at 0xffffe424	
	raise() at 0xb50048df	
	abort() at 0xb5006220	
	__libc_message() at 0xb5040e07	
	malloc_printerr() at 0xb5046e2b	
	_int_free() at 0xb5047c67	
	free() at 0xb504ba6d	
	qFree() at 0xb535a82d	
	0xb58a3573	
	0xb58a35ae	
	0xb58a38bd	
	QObject::~QObject() at 0xb548a72a	
	QLayout::~QLayout() at 0xb58a864a	
	QGridLayout::~QGridLayout() at 0xb58a1483	
	QtScriptShell_QGridLayout::~QtScriptShell_QGridLayout() at 0xb01e0820	
	QtScriptShell_QGridLayout::~QtScriptShell_QGridLayout() at 0xb01e0872	
	QWidget::~QWidget() at 0xb58d1e25	
	QGroupBox::~QGroupBox() at 0xb5d0d141	
	QtScriptShell_QGroupBox::~QtScriptShell_QGroupBox() at 0xb01e4bf0	
	QtScriptShell_QGroupBox::~QtScriptShell_QGroupBox() at 0xb01e4c42	
	RScriptHandlerEcma::ecmaDestroy() at RScriptHandlerEcma.cpp:1,271 0x87d9245	
	0xb6bd813c	
	0xb6ac1f68	
	0xb6a9164c	
	0xaa2fce4a	
	0xb6a423e3	
	0xb6af06e0	
	0xb6ac201e	
	QScriptValue::call() at 0xb6bd2e67	
	REcmaShellPropertyEditor::updateGui() at REcmaShellPropertyEditor.cpp:1,183 0x8d3b975	
	RPropertyEditor::updateFromDocument() at RPropertyEditor.cpp:226 0x8fb3f7d	
	REcmaShellPropertyEditor::updateFromDocument() at REcmaShellPropertyEditor.cpp:111 0x8d370ba	
	RMainWindow::notifyPropertyListeners() at RMainWindow.cpp:245 0x8f9de71	
	RMainWindowQt::event() at RMainWindowQt.cpp:568 0x8e86eb7	
	QApplicationPrivate::notify_helper() at 0xb5871d7c	
	QApplication::notify() at 0xb5875b64	
	QCoreApplication::notifyInternal() at 0xb547215b	
	QCoreApplicationPrivate::sendPostedEvents() at 0xb5473457	
	QCoreApplication::sendPostedEvents() at 0xb547363d	
	0xb54a2344	
	g_main_context_dispatch() at 0xb4aee509	
	0xb4aeed10	
	g_main_context_iteration() at 0xb4aeefce	
	QEventDispatcherGlib::processEvents() at 0xb54a2741	
	0xb5932a55	
	QEventLoop::processEvents() at 0xb547131d	
	QEventLoop::exec() at 0xb54715aa	
	QCoreApplication::exec() at 0xb5473701	
	qtscript_QCoreApplication_static_call() at 0xb08dc4b7	
	0xb6bd813c	
	0xb6ac1f68	
	0xb6a9164c	
	0xb083e0f4	
	0xb6a44262	
	0xb6a445f7	
	0xb6bb0f92	
	QScriptEngine::evaluate() at 0xb6bba46f	
	RScriptHandlerEcma::eval() at RScriptHandlerEcma.cpp:790 0x87d5a26	
	RScriptHandlerEcma::doScript() at RScriptHandlerEcma.cpp:786 0x87d591f	
	RScriptHandler::init() at RScriptHandler.cpp:31 0x8fbbbc2	
	main() at main.cpp:256 0x87cf40a	

Loading...