QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#433 - QScriptEngine::newVariant(): changing class of non-QScriptObject not supported

Attached to Project: QCAD
Opened by Stefan (stefan) - Wednesday, 14 December 2011, 13:31 GMT+1
Last edited by Andrew (andrew) - Wednesday, 14 December 2011, 13:36 GMT+1
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System Ubuntu Linux
Severity Low
Priority Normal
Reported Version 3 RC2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi there,

don’t know if this is a bug or not: starting QCad 3.0.0 rc2 running on Ubuntu (rc3 not yet available for Linux) prints several warnings. Console output is:

Debug: Init script plugins...
Warning: Application asked to unregister timer 0x2100000e which is not registered in this thread. Fix application.
Warning: RGuiAction::getByScriptFile: no action found: “Scheme”
Debug: TIMER: 2196 ms - “loading and initializing plugins”
Warning: QScriptEngine::newVariant(): changing class of non-QScriptObject not supported
Debug: Creating storage...
Debug: Creating spatial index...
Debug: Creating document...
Debug: Creating MDI child...
Debug: Initialize Viewports...
Debug: Init graphics view...
Debug: Init scrollbars...
Debug: Init rulers...
Debug: Init idle and default actions...
Warning: QScriptEngine::newVariant(): changing class of non-QScriptObject not supported
Warning: QScriptEngine::newVariant(): changing class of non-QScriptObject not supported
Debug: Show MDI child...
Debug: Init event handler...
Debug: updateScenes...
Debug: updateGuiActions...
Debug: notifyListenersSlot...
Warning: QScriptEngine::newVariant(): changing class of non-QScriptObject not supported
Warning: QScriptEngine::newVariant(): changing class of non-QScriptObject not supported
Warning: QScriptEngine::newVariant(): changing class of non-QScriptObject not supported
Warning: QScriptEngine::newVariant(): changing class of non-QScriptObject not supported
Debug: updateScenes...
Debug: updateGuiActions...
Debug: notifyListenersSlot...
Warning: QScriptEngine::newVariant(): changing class of non-QScriptObject not supported
Warning: QScriptEngine::newVariant(): changing class of non-QScriptObject not supported
Debug: updateScenes...
Debug: updateGuiActions...
Debug: notifyListenersSlot...
Debug: autostart.js: main(): end.

Regards - Stefan

This task depends upon

Closed by  Andrew (andrew)
Wednesday, 14 December 2011, 13:36 GMT+1
Reason for closing:  Not a bug
Additional comments about closing:  Expected behavior.

Loading...