QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#435 - QCAD3 RC3 Windows XP - Stretch command does not appear to function

Attached to Project: QCAD
Opened by Malcolm White (qcaduser2004) - Wednesday, 14 December 2011, 19:38 GMT+2
Last edited by Andrew (andrew) - Wednesday, 14 December 2011, 20:41 GMT+2
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System All
Severity Medium
Priority Normal
Reported Version 3 RC3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

The modify tools → stretch command does not appear to function.

The two attachments contain the source drawing (blackburne_engine_breather_0210A.dxf) and five screen shots (qcad3_rc3_stretch.odt) showing the steps taken to replicate the problem.

I have also performed a similar exercise with a Linux trial version 3.0 RC2 (OpenSuse 11.4) with the same result.

Regards

This task depends upon

Closed by  Andrew (andrew)
Wednesday, 14 December 2011, 20:41 GMT+2
Reason for closing:  Not a bug
Additional comments about closing:  Improvement: r20017
Comment by Andrew (andrew) - Wednesday, 14 December 2011, 20:21 GMT+2

Can you please try to 'draw' the stretch area well over the edge of the part you want to stretch as shown in the user manual at:
http://www.ribbonsoft.com/qcad/manual_reference/chapter28.html#10

Stretching means moving all end points inside the given rectangular area. If the area is drawn with a zero height or width, nothing will be stretched.

Comment by Andrew (andrew) - Wednesday, 14 December 2011, 20:40 GMT+2

Next release will allow for zero-width / zero-height box and support the way you tried to stretch.

Comment by Malcolm White (qcaduser2004) - Wednesday, 14 December 2011, 23:43 GMT+2

Thank you for the clarification. I was following what I did in v2.2.2.0. Not realising that I was missing a trick.
I have now been able to stretch the entity. Thank you for including this anomaly in the next release. Regards.

Loading...