QCAD Bugtracker

  • Status Closed
  • Percent Complete
    100%
  • Task Type Bug Report
  • Category QCAD (main)
  • Assigned To
    Andrew
  • Operating System All
  • Severity Low
  • Priority Very Low
  • Reported Version 3 RC2
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: QCAD Bugtracker
Opened by Stefan - 15.01.2012
Last edited by Andrew - 15.01.2012

FS#464 - select not possible in zoom

if drawing is zoomed too much, it is impossible to select a line with a single click (workaround: use area select)

Closed by  Andrew
15.01.2012 20:05
Reason for closing:  Fixed
Additional comments about closing:  

Problem reproducible in RC2/3 but not reproducible in current development release.

Stefan commented on 15.01.2012 18:57

"select not possible" does not mean "low severity" to me. Attached you find a screen shot in default view, where every line is selectable as expected. With little zooming (second file) NONE of the displayed lines is selectable by a single click and therefore none of the tools with two lines (e.g. trim) is working. The marked tiny line in the first view is not selectable precisely without zooming.

Admin
Andrew commented on 15.01.2012 20:04

Information for potential workaround: Problem is caused by non-zero Z level (i.e. drawing is not 2D).

Stefan commented on 15.01.2012 21:05

Thank you for the hint.

How can I check or reset one or all Z-levels? (sorry, couldn't find an answer with google or in FAQ or qcad-how-do-I.)

The drawing is created by someone else with ACad (file starts with AC1018 and shows the string "AutoCAD LT 2004\R9" somewhere inside), so I don't know the Z-levels.

Admin
Andrew commented on 15.01.2012 21:22

You would have to use a 3D CAD application for that or (if you are comfortable working with a plain text editor) modify a QCAD script as described below to allow Z coordinate editing in QCAD.

  • Open file scripts/Widgets/PropertyEditor/PropertyEditor.js with your favorite plain text editor.
  • Change the section (original code):
// don't display any Z values:
var controls;
if (title==="Z") {
    controls = undefined;
}
else {
    controls = this.initControls(propertyTypeId, onlyChanges);
}
  • Into (new code):
// don't display any Z values:
var controls;
//if (title==="Z") {
//    controls = undefined;
//}
//else {
    controls = this.initControls(propertyTypeId, onlyChanges);
//}
  • Restart QCAD
  • Select all
  • At top of property editor, choose "Selection: Line"
  • Change all Z coordinates to 0
Stefan commented on 15.01.2012 21:37

Thank you very much, I will try this as soon as possible and post the result.

Stefan commented on 16.01.2012 12:52

Confirmed, after changing to Z=0 all lines are selectable even if view is zoomed. :-)

Is there a way to set all Z-coordinates to 0? If I select all?
Choosing "Selection: Line" does not show Z-coordinates (General and in Geometry: length and angle, nothing more).
Choosing "Selection: Block Reference" gives Z-coordinates in position and scale.

The property editor rises another question: why does the selection always change back to "All"?

Thank you very much.

Stefan commented on 16.01.2012 12:53

maybe this would be a feature request: reset all Z-coordinates on load to 0?

Stefan commented on 16.01.2012 13:22

the received file or the importing of it seems to have other issues, see attached screen shot with "Parse Error"

Loading...

Available keyboard shortcuts

Tasklist

Task Details

Task Editing