QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#465 - hatch with pattern empty (solid ok)

Attached to Project: QCAD
Opened by Stefan (stefan) - Sunday, 15 January 2012, 10:39 GMT+2
Last edited by Andrew (andrew) - Wednesday, 18 January 2012, 21:30 GMT+2
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System All
Severity Low
Priority Normal
Reported Version 3 RC2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

valid hatch is not visible if filled with pattern instead of solid fill

This task depends upon

Closed by  Andrew (andrew)
Wednesday, 18 January 2012, 21:30 GMT+2
Reason for closing:  Won't fix
Additional comments about closing:  Behavior due to Z coordinate !=0. Separate issues from comments split into new tasks.
Comment by Andrew (andrew) - Sunday, 15 January 2012, 14:26 GMT+2

Please check that you are not in draft mode (View - Draft Mode) and that the pattern scale is not too large or too small.

Comment by Stefan (stefan) - Sunday, 15 January 2012, 19:33 GMT+2

Checked both (not appropriate, problem persists). Attached you find a stripped dxf to test and another, most likely interrelated problem if upper right corner point of hatch is moved (partial area disappears, correct displayed area is created through copy-paste from other drawing).

Comment by Andrew (andrew) - Sunday, 15 January 2012, 20:25 GMT+2

Seems to work fine here:

  1. Make sure Property Editor is visible
  2. Select hatch entity
  3. Change property "Solid" from yes to no
  4. Change pattern name to the desired pattern name

I suppose step 4 could have been the problem.
Please add comment if problem persists.

Comment by Stefan (stefan) - Sunday, 15 January 2012, 21:55 GMT+2

Tried both
- changing "solid" from yes to no with selecting pattern name after successful (!) creation
- selecting pattern during creation
with always the same result: solid ok, pattern not visible.

If surrounding lines are selected and copied to another (new) drawing, everything works as expected. Copying the pattern-filled area back to the original drawing, the area is
- either displayed correctly - if and only if the corner points of the filled area are not on the original lines,
- or not shown at all - if a corner point of the filled area is on one of the original lines.

Comment by Stefan (stefan) - Sunday, 15 January 2012, 22:35 GMT+2

Attached you find a screen record for the copy+paste+disappear-thing if the corner point of the pattern-filled is on an original line.
Recorded action is:
select all, hatch solid - ok - remove
select all, hatch pattern - not shown - undo
select all, copy with reference, create new drawing, paste, hatch pattern - ok
mark pattern area, copy with reference (upper right point), paste in original drawing, switching between snapfree (ok) / snapend (area disappears) toggles visibility of filled area

   out.ogv (1.84 MiB)
Comment by Andrew (andrew) - Sunday, 15 January 2012, 22:41 GMT+2

This is very likely also connected to the drawing entities not being 2D (Z coordinates != 0).

Comment by Stefan (stefan) - Monday, 16 January 2012, 13:44 GMT+2

Confirmed, thank you very much for your support and the suggested modification of PropertyEditor.js!

After changing Z-coordinate of lines to 0 everything works as expected.

Comment by Stefan (stefan) - Monday, 16 January 2012, 15:24 GMT+2

unfortunately, after saving and re-opening the pattern-filled object is removed (not invisible, it is not existing; inserted as single object on new layer, layer is empty after re-open)

Comment by Stefan (stefan) - Monday, 16 January 2012, 20:08 GMT+2

After some more testing it seems that the original data had everything with Z=0. Copy+Paste with paste in a new drawing results in Z=-13.6... which caused the problems of pattern-hatch and select-impossible.

How can I help to burn down this bug?

Comment by Stefan (stefan) - Wednesday, 18 January 2012, 00:33 GMT+2

After more testing, it seems that a solid triangle causes trouble, perhaps correlated to Z-coordinates and the property editor.

Attached you find a dxf example file with only 7 objects. Three noticable cases:
- Selecting all and change Selection in the property editor to "Solid" flips to "No Selection" although objects selected.
- Selecting all and change Selection in the property editor to "Line" shows "Length" and "Angle" in Geometry with "*VARIES*" values although only one line is selected.
- Selecting all but the solid object (6 objects selected now), everything works as expected, in particular Selection "Line" shows valid values (and Z-coordinate 0).

I hope this helps, please give instructions how to help if necessary.

   tmp.dxf (174.6 KiB)
Comment by Andrew (andrew) - Wednesday, 18 January 2012, 21:11 GMT+2

The last comment seems to be a separate issue and has been split into  FS#469 

Comment by Andrew (andrew) - Wednesday, 18 January 2012, 21:30 GMT+2

Comment from Monday, 16 January 2012, 19:08 GMT has been split into  FS#470 

Loading...