QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#478 - crash on "Draw" - "Insert Bitmap"

Attached to Project: QCAD
Opened by Stefan (stefan) - Tuesday, 31 January 2012, 14:30 GMT+2
Last edited by Andrew (andrew) - Friday, 09 March 2012, 12:01 GMT+2
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System Ubuntu Linux
Severity High
Priority Normal
Reported Version 3 RC2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Selecting “Draw” and “Insert Bitmap” from the menu shows file dialog “Import Bitmap” for a split second and then crashes completely with segmentation fault.

Running Ubuntu Linux 10.04 LTS with QCad3 rc2.

Console output:
Debug: updateScenes...
Debug: updateGuiActions...
Debug: notifyListenersSlot...
Warning: RScriptHandlerEcma::createActionDocumentLevel(): “scripts/Snap/RestrictOff/RestrictOff.js” : Engine is busy. Aborting...
Warning: RScriptHandlerEcma::createActionDocumentLevel(): “scripts/Snap/SnapAuto/SnapAuto.js” : Engine is busy. Aborting...
/opt/qcad-3.0.0-rc2-prof-linux/qcad: line 35: 5905 Segmentation fault LD_LIBRARY_PATH=”$DIR” “$binary” $OPT1 $OPT2 “$@”

This task depends upon

Closed by  Andrew (andrew)
Friday, 09 March 2012, 12:01 GMT+2
Reason for closing:  Fixed
Additional comments about closing:  See comments for workaround implemented in next release.
Comment by Andrew (andrew) - Tuesday, 31 January 2012, 19:40 GMT+2

Thanks for your report.

Is this a reproducible? I.e. does this happen every time you try to insert a bitmap, even into an empty drawing or was this a one time 'random' problem?

Comment by Stefan (stefan) - Tuesday, 31 January 2012, 19:56 GMT+2

It is reproducible even after machine reboot, attached you find a screen recording. I tried several times, in about 40 checks (reboot, logout, login etc.) in one single case the dialog appeared as expected.

   out.ogv (903.4 KiB)
Comment by Stefan (stefan) - Tuesday, 31 January 2012, 20:04 GMT+2

Perhaps you have the symbol information for the calling stack... Running qcad with gdb gives:
...
Debug: calling initUiOptions: false
Warning: RScriptHandlerEcma::createActionDocumentLevel(): "scripts/Snap/SnapAuto/SnapAuto.js" : Engine is busy. Aborting...
Warning: RScriptHandlerEcma::createActionDocumentLevel(): "scripts/Snap/RestrictOff/RestrictOff.js" : Engine is busy. Aborting...
[New Thread 0xb26c4b70 (LWP 2865)]
[New Thread 0xb1cffb70 (LWP 2866)]
Debug: updateScenes...
Debug: updateGuiActions...
Debug: notifyListenersSlot...
[Thread 0xb1cffb70 (LWP 2866) exited]
Warning: RScriptHandlerEcma::createActionDocumentLevel(): "scripts/Snap/RestrictOff/RestrictOff.js" : Engine is busy. Aborting...
Warning: RScriptHandlerEcma::createActionDocumentLevel(): "scripts/Snap/SnapAuto/SnapAuto.js" : Engine is busy. Aborting...
[New Thread 0xb1cffb70 (LWP 2867)]
[New Thread 0xb14feb70 (LWP 2868)]
[New Thread 0xb0cfdb70 (LWP 2869)]
[New Thread 0xb04fcb70 (LWP 2870)]
[New Thread 0xafcfbb70 (LWP 2871)]
[New Thread 0xaf4fab70 (LWP 2872)]
[New Thread 0xaecf9b70 (LWP 2873)]
[New Thread 0xae4f8b70 (LWP 2874)]
[New Thread 0xadcf7b70 (LWP 2875)]

Program received signal SIGSEGV, Segmentation fault.
0x09af6624 in FT_Open_Face ()

Comment by -- (clive) - Thursday, 09 February 2012, 21:37 GMT+2

For info:I have recently (6/2/2012) used some Bitmap images with no problems on Ubuntu 11.10

Comment by Andrew (andrew) - Wednesday, 07 March 2012, 20:16 GMT+2

Please indicate whether this problem persists with QCAD 3 RC4.

Comment by Stefan (stefan) - Thursday, 08 March 2012, 14:40 GMT+2

Tried QCAD 3 RC 4 (this is much :-) faster!), unfortunately the problem persists: for a split second, the "Import Bitmap" dialog (to be precise: the frame of this dialog) appears, then QCad crashes with segmentation fault.

I'm running an up-to-date XUbuntu 10.04, maybe something is missing in Xfce?

Comment by Andrew (andrew) - Friday, 09 March 2012, 11:11 GMT+2

This might indeed be something unique to XUbuntu / Xfce. I'll try to reproduce when I have the time.

Comment by Andrew (andrew) - Friday, 09 March 2012, 12:00 GMT+2

Alright, looks like a bug in one of the libraries involved with Xfce.

Attached, you can find a workaround. Please copy this file into scripts/Draw/Image/Image.js and overwrite the existing file.

   Image.js (8.2 KiB)
Comment by Stefan (stefan) - Friday, 09 March 2012, 20:03 GMT+2

confirmed - with the new Image.js (2012/03/09-12:00) everything works as expected.

Thank you! :-)

Loading...