QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#545 - russian codepage error in Layer list

Attached to Project: QCAD
Opened by Dmitry Mikhailov (scaramush) - Thursday, 12 April 2012, 15:39 GMT+1
Last edited by Andrew (andrew) - Monday, 16 December 2013, 14:34 GMT+1
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System All
Severity Low
Priority Normal
Reported Version 3 RC5
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

1. Creating new file
2. create new layer with cyrilic name, ex.: фыва screenshot #1
3. saving
4. closing
5. look in file see correct UTF-8 name screenshot #2
6. opening file via qcad/ oops! layer name is incorrect screenshot #3
7. saving file
8. closing
9. look in file. got incorrect version

my guess, that the problem is that whole file is encoded as ANSI:

$DWGCODEPAGE
  3
ASCII
  9

but layer names are coded as UTF-8.
so additional converting ANSI→UTF-8 is demanded

This task depends upon

Closed by  Andrew (andrew)
Monday, 16 December 2013, 14:34 GMT+1
Reason for closing:  Won't fix
Additional comments about closing:  No reply from reporter
Comment by Andrew (andrew) - Thursday, 04 July 2013, 00:50 GMT+1

There have been some improvements in that area (codepage support) in QCAD 3.1.4.
Dmitry, could you check if that problem still persists?

Loading...