QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#548 - russian codepage error in text tool

Attached to Project: QCAD
Opened by Dmitry Mikhailov (scaramush) - Saturday, 14 April 2012, 10:27 GMT+2
Last edited by Andrew (andrew) - Monday, 16 December 2013, 14:34 GMT+2
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System Windows 7
Severity Low
Priority Normal
Reported Version 3 RC5
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

1. add any russian (cyrillic, for example йцук) text via text tool
2. save file
3. close file
4. open file
5. voila (see attached screenshot)

This task depends upon

Closed by  Andrew (andrew)
Monday, 16 December 2013, 14:34 GMT+2
Reason for closing:  Won't fix
Additional comments about closing:  No reply from reporter
Comment by Andrew (andrew) - Saturday, 14 April 2012, 11:48 GMT+2

I am trying to reproduce the problem here:

- Since I cannot enter Russian on my keyboard, I go to google.ru and copy some russian text, e.g. "Открывай любимые сайты быстрее".
- I create a text with that content using the font 'Arial'.
- I save the file and re-open it. This seems to work fine (Windows 7, QCAD 3 RC5).

Could it be that you are entering Russian text somehow differently, e.g. by using a special (non-Unicode) font that has Russian letters where other fonts have latin letters 'A', 'B', 'C', ..?
What is the name of the font you are using?

Comment by Dmitry Mikhailov (scaramush) - Tuesday, 17 April 2012, 10:32 GMT+2

no, i use Arial, too. My OS is Windows 7 64 bit
this bug appaered when i install QCAD 3 RC5 (not RC5b)
Before i have installed QCAD 3 RC3 and everything works fine. QCAD 2 doesn't support russian codepage so, I tryed to use cyrillic symbols in QCAD 3. Everything was ok.
Then i installed QCAD 3 RC5 And successfully remove it (because of a bug with icons)
SO try to install QCAD 3 RC3 and get error in codepage in my drawings.
I try to remove QCAD 3 RC3 and install QCAD 3 RC5 and got same bug

Comment by Dmitry Mikhailov (scaramush) - Tuesday, 17 April 2012, 10:37 GMT+2

I think this is same problem with error with russian codepage in layer names
I tried to look into dxf file and I can see, that file is saved correctly, in UTF-8, but opens incorrect way somewhere additional translation is nesessary.

Comment by Andrew (andrew) - Tuesday, 17 April 2012, 10:45 GMT+2

Could you attache a drawing file? I cannot reproduce the problem here. Thanks!

Comment by Dmitry Mikhailov (scaramush) - Tuesday, 17 April 2012, 10:54 GMT+2

1. Create new file
2. Writing text "верх шкафа 2 шт\p18 мм фанера" text is same with previos screenshot
3. Save to file 1.dxf
4. Opens file (got error in cyrrilic codepage like previos screenshot)
5. Save to file 2.dxf

look to 2544 line in both files

   1.dxf (39.9 KiB)
   2.dxf (39.9 KiB)
Comment by Andrew (andrew) - Tuesday, 17 April 2012, 11:17 GMT+2

Thanks. I followed your instructions and this seems to work just fine here. I will have a look at the files you posted to see what's going on on your installation.

Comment by Andrew (andrew) - Thursday, 04 July 2013, 00:49 GMT+2

There have been some improvements in that area (codepage support) in QCAD 3.1.4.
Dmitry, could you check if that problem still persists?

Loading...