QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#552 - autosave removing last auto saved file

Attached to Project: QCAD
Opened by Stefan (stefan) - Sunday, 15 April 2012, 20:10 GMT+2
Last edited by Andrew (andrew) - Wednesday, 06 June 2012, 09:28 GMT+2
Task Type Feature Request
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System All
Severity Medium
Priority Normal
Reported Version 3 RC5
Due in Version 3.0.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I would like to see an autosave-option which allows to autosave, but which keeps only the latest autosave file (instead of all). So there would be autosave (if something crashes) but the hard disk is not filled up too fast.

This task depends upon

Closed by  Andrew (andrew)
Wednesday, 06 June 2012, 09:28 GMT+2
Reason for closing:  Implemented
Comment by Garcia (plgarcia) - Sunday, 27 May 2012, 12:30 GMT+2

The autosave available in the rc5 version function saves in the home of the user.
That is not a good behaviour.
- First because you leave without knowing a copy of your file on all PC you edit the file, that is really bad for confidential reasons.
- Second because it should be a temporary file.

It would be better to autosave in the folder where the original file is (eventually on and usb drive), with a really identified file starting with à ~ as word does.
This character allows to parametrized synchronisation program not to take these files.

When the save or save as occurs this file should be removed.
When qcad opens a file for witch an autosave file exists, it could ask whether to discard the changes or to keep them. If "keep changes" is selected the original file must not be automatically replaced, the information "recovered" shoul be displayed in the tab header and only "save as" should be possible to be certain that the user really wants to discard the original file.

If special care is taken while saving all this can ensure no data is lost or leaked (ie save the data in a temp file , and when saved whith no errors the file is renamed).

Of course errors at all level must be handled.

Comment by Andrew (andrew) - Monday, 28 May 2012, 11:33 GMT+2

Agreed. This will be mostly implemented like that in QCAD 3 final.

Confidentiality might still be an issue in the following situation:
- User works on a drawing that was not saved yet (untitled)
- QCAD autosaves to home (not much choice, as intended location of file is unknown)
- QCAD is terminated or crashes

This situation might be avoided with a user preference to never autosave untitled files.

Comment by Garcia (plgarcia) - Tuesday, 29 May 2012, 07:59 GMT+2

I think that for untitled files it is OK to use the home dir, as it is a new document done by the user.
But when saving to the final location the file should dissapear.

The autosave file should also dissapear when living QCad and the choice is made by the user not to save the file. So the only case a file stays would be when QCad crashes : almost never.

An option is a good idea to disallow autovave but should concern all cases.

Loading...