QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#580 - Black color reverted to white color on each close

Attached to Project: QCAD
Opened by Michel-Henri GONZE (MiHeGo) - Friday, 27 April 2012, 12:01 GMT+2
Last edited by Andrew (andrew) - Saturday, 28 April 2012, 11:00 GMT+2
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System Windows 7
Severity Medium
Priority Normal
Reported Version 3 RC5
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hello,

When I started Q3, I selected a White background in the initial dialog window. I opened a copy of a good Q2 file and saw that ALL entities with Q2 Black/White color where forced to be White. Andrew explains this as a mean to avoid unreadable items against the background colors. Remember I selected White as background ? I guess Black/White entities could be better kept as Black ?

Following Andrew’s advice, in Application Preferences =⇒ Graphics View, I unchecked the Auto correct black and white colors check box. The background settings is white. OK.

I went through a process of changing the White color for several layers to Black. I also had to change the color codes for the hatch areas. For instance, the hatch area layer “055_F_Murs” has “14-76-255 / 255-197-179” values in Q2. Why these values are auto corrected to “30-128-255 / 255-191-127” ?

After these changes, I saved the file, closed Q3 and opened the file again.

Catastrophique ! All “Black/White” layers were back to Black and the hatch colors were back to the “auto corrected” values.

Changing the background color to black then white seemed to solve the problem : the layers kept the Black color. Actually it was just an illusion.

Yesterday too much confident, I spent the whole day, modifying layers to Black, adding new layers also Black or custom color, checking the line weight (replacing the “default” (?) value of 0.25 mm with my preferred default value of 0,00 mm, I’ve posted on the forum about this) and so on. I saved the file, closed it.
To-day, nearly all layers have lost their colors :
- Black ones are again White,
- custom color are “auto corrected” as above for “055_F_Murs”,
- only the standard non Black/White colors are preserved, like Blue, Magenta etc.

At this point, I can’t continue using QCAD 3 with enough reliability as my color settings are always lost. This is why I qualify this bug as CRITICAL.
I don’t want to use a Black background or a Light Blue one. Why do you think all old “green on black VDU” were replaced with “black/color on white” displays, to begin by Apple ?

NB I already reported this but can’t find it in the list (maybe because I forgot to enter a summary ? No warning, happily I had a copy with Notepad), sorry for the duplicate.

This task depends upon

Closed by  Andrew (andrew)
Saturday, 28 April 2012, 11:00 GMT+2
Reason for closing:  Fixed
Additional comments about closing:  There's no fix as this is a file format limitation.

To improve the user experience, a warning is shown when using a file format version that does not support 24bit colors.
Comment by Andrew (andrew) - Friday, 27 April 2012, 12:14 GMT+2

Changed to normal. Bug severity is not meant to be subjective (each user has his own one 'critical' feature request or bug report).
Critical bugs are: crashes, not able to save / load, etc.

Comment by Michel-Henri GONZE (MiHeGo) - Friday, 27 April 2012, 14:54 GMT+2

Andrew wrote « Critical bugs are: crashes, not able to save / load, etc. ».
Exactly ! The point is that when I save the file, later I don't find what I saved : translated "I'm not able to correctly save my job".
Anyway, no matter the severity qualification, I ceased to use QCAD rc5 for its lack of reliability in its current delopment stage. I desinstall it and I'll wait for a new release before giving it a try !

Comment by Andrew (andrew) - Saturday, 28 April 2012, 10:51 GMT+2

User is using an older version of DXF/DWG (⇐R15 / DXF2000) which does not support black colors nor custom colors.

Fix: warn user when he's doing this.

Workaround: Save as - Choose moden file version ( > DXF2000 / R15).

Loading...