QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#582 - Standard font from QCad2.2 has to be explicitly set back when editing

Attached to Project: QCAD
Opened by james a r brown (jamesarbrown) - Monday, 30 April 2012, 15:54 GMT+1
Last edited by Andrew (andrew) - Thursday, 03 May 2012, 11:38 GMT+1
Task Type Bug Report
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System Linux (All / Other)
Severity Low
Priority Normal
Reported Version 3 RC5
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi,

If you open an old qcad drawing thats DXF and edit text, the popup window shows “Main Font” as empty.

If you do not set the font and complete the edit, it will change the font from the standard to what looks like an Arial font.

If you set the font as “standard” during the edit, each time in future you open the editor it does at least have standard selected.

Ie if no font is specified in drawing, should it not select “standard”?

James

This task depends upon

Closed by  Andrew (andrew)
Thursday, 03 May 2012, 11:38 GMT+1
Reason for closing:  Fixed
Additional comments about closing:  r21461
Comment by Andrew (andrew) - Monday, 30 April 2012, 19:18 GMT+1

Please submit a file for testing if you have one (you can attach it to the bug report or e-mail it to info at ribbonsoft dot com).
I've tried to reproduce the problem with QCAD 2.2 and QCAD 3 RC5 but haven't succeeded yet.
Thanks.

Comment by james a r brown (jamesarbrown) - Monday, 30 April 2012, 21:54 GMT+1

Hi Andrew,

Herewith file. If you open it, you will already notice a mixture of fonts around the title area, the two line on the title, first line edited with Qcad3rc5, second line Qcad 2.2.2Pro.

If you start QCad3rc5, select the text edit tool, select the second title line hopefully it will show an empty box for the font.

James

Comment by Andrew (andrew) - Thursday, 03 May 2012, 11:38 GMT+1

Thanks for the file. The fonts of some texts are set to '' in the file. The next release will replace those fonts with 'standard'.

Loading...