QCAD

QCAD - 2D CAD System.

Click here for a documentation of the DokuWiki formatting syntax that can be used in reports

Please search for existing tasks (also closed ones) before opening a new task.

Please make sure that you are using the latest Version of QCAD before posting a bug (menu Help - Check for Updates)

Tasklist

FS#607 - Warning needed

Attached to Project: QCAD
Opened by Garcia (plgarcia) - Sunday, 27 May 2012, 16:05 GMT+2
Last edited by Andrew (andrew) - Thursday, 31 May 2012, 10:57 GMT+2
Task Type Feature Request
Category Main
Status Closed
Assigned To Andrew (andrew)
Operating System All
Severity Low
Priority Normal
Reported Version 3 RC5
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When trying to Move an object to a layer that is locked nothing happens and no warning, so it difficult to figer out what is the reason.

The same happens when the default layer is locket. No way to add an object and no warning helps to understand what is going on.

A warning message should be displayed when such a situation occurs.

May be the default layer should never be locked.

[Edit: warnings are display in the command line history]

This task depends upon

Closed by  Andrew (andrew)
Thursday, 31 May 2012, 10:57 GMT+2
Reason for closing:  Implemented
Additional comments about closing:  r21628
Warnings can be optionally shown as pop-up dialog
Comment by -- (clive) - Monday, 28 May 2012, 12:49 GMT+2

On Windows 7 -64
I cannot reproduce this.
My test case:
1.Set up layer 1 and layer 2.
2.Draw object on layer 1.
3.Using either Modify > Move/Copy or via the property Editor > General > Layer -move object to layer 2 (locked).
4.Warning in the command line (to view the command line > View > tool bars > command line or 'right click' on a tool bar and tick to view the command line) displayed as - "Trying to draw on or modify entities on a locked layer"

Comment by Husky (Husky) - Monday, 28 May 2012, 22:56 GMT+2

Objection ;-)

It is easily reproducible and I thing he/she is right. I would call it a bug and a feature request.

Test Case: Layer 1 with a circle on it. Layer 2 locked/unlocked/activated/deactivate.

If you use the move and copy tool with a visible command line then you get the Info:

Trying to draw on or modify entities on a locked layer .... and it happens nothing else.

I suggest to change this Warning in:

Denied - Trying to draw on or modify entities on a locked layer.

If you work with copy/paste it doesn't works how expected and it doesn't matter which Layer is activated or locked.
QCAD copy and paste it always on the same Layer.
That is for me a bug.

If you work like me mostly without the visible Command line then you get no Information what is going on.
Try to copy the circle from Layer 1 on the locked Layer 2. The circle will just disappear without any Information what happened. Confusing!
That is for me a Feature request so that we get the same Info as a "no Command line user" in a Popup window like:
Denied - Trying to draw on or modify entities on a locked layer.

.... just two cents from a user ;-)

Comment by -- (clive) - Monday, 28 May 2012, 23:54 GMT+2

Ahh - My mistake, at work I can achieve this with RC4 (working OK I have not upgraded on this computer to RC5 yet) and it works fine with Move/Copy or via the property Editor and I get the warning in the command line when trying to work on a locked layer.

Now at home on RC5 I agree I get the same results as you. So its strange that it`s working on RC4 but not RC5 - so yes a bug!

I always have the command line visible, but I agree yes there should be a warning even without the command line.

Comment by -- (clive) - Tuesday, 29 May 2012, 00:24 GMT+2

Re - Copy/Paste

1.On layer 1 draw circle.
2.Select circle > Copy with reference (center).
3.Select layer 2 then 'paste' - make sure in the toolbar - 'To current layer' is ticked, job done!

Comment by Husky (Husky) - Tuesday, 29 May 2012, 09:16 GMT+2

Comment by Clive Tubb (clive) - Monday, 28 May 2012, 22:24 GMT 3.Select layer 2 then 'paste' - make sure in the toolbar - 'To current layer' is ticked, job done!

Correct! My mistake - I haven't ticked "To current layer" oops.

I use the Command Line rarely because it reminds me to much on the old DOS Ara. I like much more to work only in one Modus and in this case it's the graphical user interface.

Comment by Andrew (andrew) - Thursday, 31 May 2012, 10:19 GMT+2

Working without command line is not recommended at this point. Warnings are indeed displayed in the command line only. Also some results displayed by the information (measuring) tools are only displayed in the command line history.

Layer 0 has to be lockable by definition (file format spec). A loaded drawing might have layer 0 locked already.

Loading...